summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 20:11:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 22:30:22 +0100
commit3fa6d920893766911f27b7775c0492b409944e6a (patch)
tree108d14d03f0cae1229fb85b03791e4cc3f3a8bb9 /kde-apps/kldap
parentkde-frameworks: Add KDE Frameworks 5.64.0 (diff)
downloadgentoo-3fa6d920893766911f27b7775c0492b409944e6a.tar.gz
gentoo-3fa6d920893766911f27b7775c0492b409944e6a.tar.bz2
gentoo-3fa6d920893766911f27b7775c0492b409944e6a.zip
kde-apps: Add KDE Applications 19.08.3
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kldap')
-rw-r--r--kde-apps/kldap/Manifest1
-rw-r--r--kde-apps/kldap/kldap-19.08.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/kldap/Manifest b/kde-apps/kldap/Manifest
index 8b0e7bdb9ff2..ec3f1e3875ec 100644
--- a/kde-apps/kldap/Manifest
+++ b/kde-apps/kldap/Manifest
@@ -1,2 +1,3 @@
DIST kldap-19.04.3.tar.xz 155680 BLAKE2B f6f8c7197666883e3c707190ed8f342ab9ee13116dc625070800e8f0db61a9613522d50f93427b8d4552e840ea5dc507223054dc519a7445dd7b1c35cd0718dc SHA512 0e0d02cf9330fd34caf186bf1220b18a68d88dc12391eb6f7af4bea25a75fc187cb6c12fc359aebfc94d38c8d871cb481567432fd34bf489c316b45d3eb78480
DIST kldap-19.08.2.tar.xz 155428 BLAKE2B adcfd1cdddb1207e86e63e7726e2f345a9aebd644d70a2f33fce7daef9769894377cc673c7fcf86d42bd87eb497d9ca2bb7764ccc22fe138f8f3f62622ca02f6 SHA512 55f71ab415b6df4d7daf7cf065c6292a6b480cb09bdbe667d0266585244776a5cb2044b1b8e8935624d454f49f334aef3f30ce0f66594eb54c16482eaaf3506b
+DIST kldap-19.08.3.tar.xz 155372 BLAKE2B df9dd8216da743db09e9e059067a91c4776e26847f1413f281708fdb04372aed7186e7a0b2d1d2bf04a5cca657cfee290c7fa14470c7d1b64244284fafb65213 SHA512 c2e21c0b3755228aea5b2612cb495565aa2161e3502b1d72b5063eb2ee15b4ea1ee820b8183b2820607bc1b0e2eaf33a6983eaa025c2224e557f10dd17fc9d37
diff --git a/kde-apps/kldap/kldap-19.08.3.ebuild b/kde-apps/kldap/kldap-19.08.3.ebuild
new file mode 100644
index 000000000000..5ebdfc0f149c
--- /dev/null
+++ b/kde-apps/kldap/kldap-19.08.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with LDAP servers"
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ dev-libs/cyrus-sasl
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ if ! use handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}