summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/kldap
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kldap')
-rw-r--r--kde-apps/kldap/Manifest1
-rw-r--r--kde-apps/kldap/kldap-17.12.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-apps/kldap/Manifest b/kde-apps/kldap/Manifest
index 11c6102285b6..4faea867cc5c 100644
--- a/kde-apps/kldap/Manifest
+++ b/kde-apps/kldap/Manifest
@@ -1 +1,2 @@
DIST kldap-17.08.3.tar.xz 154864 BLAKE2B ecf22ab36150da39dcaa34b391864a7e6f7b3d4335e998089c9c7ebf582436aab0bd59cb3e04572dff74b2125ec5c243f8b2413bcb5be71168de4f44e3a30120 SHA512 b32fa8dfc9125a4f944aea710871268c64492cd4753a6be6f48f4bf314f9c66e56493c0d1bec0d3420edb6998971a9e1d941a050c038764e07b323b9dde8be53
+DIST kldap-17.12.0.tar.xz 155088 BLAKE2B a2db7e2a24ade3effa0fc74f36ca06182d0dbff582fa8f1a1665d4844ae1257f907317681b8f5a65eee5dfb099f4de1abe83e7114af01e717020873432121675 SHA512 1b53624a6aca494e3b249eb6cf1fbc8b89ab1412d31e9346c913d63c9080d6d10fc03ffd5f203a59260819b8c3b57a63ef67eb9c2d85de0049d94465acb33117
diff --git a/kde-apps/kldap/kldap-17.12.0.ebuild b/kde-apps/kldap/kldap-17.12.0.ebuild
new file mode 100644
index 000000000000..b55334312e57
--- /dev/null
+++ b/kde-apps/kldap/kldap-17.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library for interacting with LDAP servers"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/cyrus-sasl
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use_if_iuse handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}