summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/kldap
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kldap')
-rw-r--r--kde-apps/kldap/Manifest1
-rw-r--r--kde-apps/kldap/kldap-19.08.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/kldap/Manifest b/kde-apps/kldap/Manifest
index a791c2bdf3e3..241befa77020 100644
--- a/kde-apps/kldap/Manifest
+++ b/kde-apps/kldap/Manifest
@@ -1 +1,2 @@
+DIST kldap-19.08.3.tar.xz 155372 BLAKE2B df9dd8216da743db09e9e059067a91c4776e26847f1413f281708fdb04372aed7186e7a0b2d1d2bf04a5cca657cfee290c7fa14470c7d1b64244284fafb65213 SHA512 c2e21c0b3755228aea5b2612cb495565aa2161e3502b1d72b5063eb2ee15b4ea1ee820b8183b2820607bc1b0e2eaf33a6983eaa025c2224e557f10dd17fc9d37
DIST kldap-19.12.3.tar.xz 155404 BLAKE2B 978e693f19f0ff0258d963d758d18ea865d76b552a7f6fb10afeaec409f558fbc5f459447c491f226891351cf254cb081091dbd8ee4644dd1a70013fa024af86 SHA512 5c0446d31c34d018910f50d0edc947400798a33af3a41b77989dd80f8657b13f71472aa3a2eafd5d51c703f7e72a76a6279bb9c93b1cdc4fc7dc8c676ef17435
diff --git a/kde-apps/kldap/kldap-19.08.3.ebuild b/kde-apps/kldap/kldap-19.08.3.ebuild
new file mode 100644
index 000000000000..4bd3795d37f4
--- /dev/null
+++ b/kde-apps/kldap/kldap-19.08.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with LDAP servers"
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="arm64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ dev-libs/cyrus-sasl
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ if ! use handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}