summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 12:40:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 16:29:37 +0200
commit77996f0bd46af757187d387e251f25fdf21a33f8 (patch)
tree18c9cc45de05d82b4e08b5966b62d51dc802872e /kde-apps/kolourpaint
parentwww-client/opera-beta: Old (diff)
downloadgentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.gz
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.bz2
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.zip
kde-apps: Add KDE Applications 19.04.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-19.04.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index 2d3b164f569f..dd067b65c1de 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1 +1,2 @@
DIST kolourpaint-18.12.3.tar.xz 5651092 BLAKE2B 11a7dc906d0240524944d4aa4d61087f2b0689658dc8903eaddf38a3a1a052d19949cf550ed7f117f60892bc382b5cb251107db5d3acdda7bf019b912c71db13 SHA512 ac294aa80ffebdc6440474c15c5450fdcf15d735e6d920e2af99c92cbaa5f8930330a268faea5fb7859d1128c7479049ceb672715d7a4dbfdfb7e3b72157af13
+DIST kolourpaint-19.04.0.tar.xz 5656056 BLAKE2B df78b789bb95a0ddb223af20dbeac955e70735aebd494f9095aac40bd391c0659658700b1e93253b6658c84e7f98bc097224a3e713d82ead3793a054c1369cf2 SHA512 e0bc3084c1f39196c10344e4a941e55783fde14a4832aa65e59e32d09e33d96cfe9904e6c24adb75d3297eaedf387ec8f77c6edcdd93de4664c26be33e514931
diff --git a/kde-apps/kolourpaint/kolourpaint-19.04.0.ebuild b/kde-apps/kolourpaint/kolourpaint-19.04.0.ebuild
new file mode 100644
index 000000000000..d36c8c7865a0
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-19.04.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://kde.org/applications/graphics/kolourpaint/"
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="scanner"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ scanner? ( $(add_kdeapps_dep libksane) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ )
+
+ kde5_src_configure
+}