summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-04-20 18:15:02 +0200
committerJohannes Huber <johu@gentoo.org>2017-04-20 18:22:40 +0200
commit8f00b2bf566d896205f52099530159c97b977f68 (patch)
tree6dfeae9f7a9dc7b276cb384a7f4ad8d589de52d1 /kde-apps/kolourpaint
parentkde5*eclass: KDE Applications 17.04.0 improvements (diff)
downloadgentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.gz
gentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.bz2
gentoo-8f00b2bf566d896205f52099530159c97b977f68.zip
kde-apps: Version bump KDE Applications 17.04.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-17.04.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index cb227a9f97cf..ee729e9cabad 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1 +1,2 @@
DIST kolourpaint-16.12.3.tar.xz 879332 SHA256 ebb3dde7bbcdc289083a873169cb08e013fc02517e8914cf7a0ceebf96ede3f9 SHA512 7d3a6fd104dd8567a5bebf092d507e4f03ad6f53216e4246477508be1854ee60624c154c81c47647ad83be4b498f1a3d248539ecab30ba75b14b7c3936a305ac WHIRLPOOL f4e7b73602d7f0cda5972fec0e86cf8698524e6c54e78b11e8b03983549154398c01e140a933f80e1315e4750ec42cbad01593da5e6d269004854f985955e5d4
+DIST kolourpaint-17.04.0.tar.xz 5552260 SHA256 b01fc3a2a43f2225dd35bc147b283567b16406772d08b82c2fd40e8a41bfbce2 SHA512 7f287f9b046fc5c6475b8da4da8172b3d9bc2939e9ef56a3ac837ece67a5fcc2c57bca61d4bf70ec5ec7cc97b7d691bfc68ca28656ce9b6a9ac2b65891f36023 WHIRLPOOL 37f0d92c89add7ecacf9c17cc23ef56a6c65e4dec7273648ef46a914c8a33e584a072675f6c774b85815ff09bee0eccd86869b0663d043de689d4d9de5afdef0
diff --git a/kde-apps/kolourpaint/kolourpaint-17.04.0.ebuild b/kde-apps/kolourpaint/kolourpaint-17.04.0.ebuild
new file mode 100644
index 000000000000..8e7b57d9beba
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-17.04.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://www.kde.org/applications/graphics/kolourpaint/"
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+IUSE="scanner"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ scanner? ( $(add_kdeapps_dep libksane) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ )
+
+ kde5_src_configure
+}