summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-04 11:08:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-04 22:27:51 +0100
commitb863d475a88536158e1b20dbdbbfe280efe4f2c6 (patch)
treef3c228621c6bba89645b7bd8aa22c911ff3854e1 /kde-apps/konsolekalendar
parentkde-apps/knotes: 20.12.3 version bump (diff)
downloadgentoo-b863d475a88536158e1b20dbdbbfe280efe4f2c6.tar.gz
gentoo-b863d475a88536158e1b20dbdbbfe280efe4f2c6.tar.bz2
gentoo-b863d475a88536158e1b20dbdbbfe280efe4f2c6.zip
kde-apps/konsolekalendar: 20.12.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-20.12.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 36783e8c4152..e8e556da9ecb 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1 +1,2 @@
DIST akonadi-calendar-tools-20.12.2.tar.xz 224864 BLAKE2B 137a0d975242b2e419007ebc9be0eaac55e5f024b708c78fb773158695a0bb0b673657b8634423826eeba03cfdab75ff7e85bcc6ce09e33372a0927490d0b9b8 SHA512 12ed3517ec1a308bbb80691bb1fccf29a2a44c9715436288f51aa5eeffee25c3842d6664c1bfbe7c2ac669806d5ae0f0123bc1dece279953abd95feaafafff81
+DIST akonadi-calendar-tools-20.12.3.tar.xz 224860 BLAKE2B 0f03e653c6cde40a1288fe24d92d612e238768fe38f9c10e7ddf0a20c18cdc8ce44c85e416a0535bf45a8730dee33358a8027a2c7a67442e98d65066de5c3109 SHA512 5890454e49f4cfb04e3edb4895eb4f4f7abfba691185ccc9b9b3c3efc3d675cfe8c7b493b3378143d5da552ff784a391fd194c7107e4ddd11434aa3c130e5d56
diff --git a/kde-apps/konsolekalendar/konsolekalendar-20.12.3.ebuild b/kde-apps/konsolekalendar/konsolekalendar-20.12.3.ebuild
new file mode 100644
index 000000000000..64a6a8c373dd
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-20.12.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.75.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}