summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-09 19:42:23 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-09 19:42:37 +0100
commit0e7c442531fd2caefa9035ffc99514dc94432083 (patch)
tree7a07bfea1f2927843db5bef673bb696eac1a32a6 /kde-apps/kopete
parentmultiprocess.eclass: makeopts_{jobs,loadavg}: fix implicit handling of $MAKEO... (diff)
downloadgentoo-0e7c442531fd2caefa9035ffc99514dc94432083.tar.gz
gentoo-0e7c442531fd2caefa9035ffc99514dc94432083.tar.bz2
gentoo-0e7c442531fd2caefa9035ffc99514dc94432083.zip
kde-apps: Version bump KDE Applications 16.12.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-16.12.2.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 27b26e8360f7..1b94b0bdb625 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-16.12.0.tar.xz 6340832 SHA256 c0ecf2c7d2bb679f523d043b27f51120846a812fad8aabfcc6b33c81718f2789 SHA512 7ea765ebb8652773734b98d9287b9a81452d390b86f80b1c34e166491762791666593e68204100cf18b2245f42a4aabcf4c433c02280d116ec814b93613885fe WHIRLPOOL 67f1bb33d2e009e592f69ff462a7e72471b51a68669abad1760921139dcfc74ec12963c410190de7f15a8f0e62f79357f4680aeb756faa37d820b9122268d836
DIST kopete-16.12.1.tar.xz 6340756 SHA256 c2667e4ef651f37c88df56d84c75f3628e40c920962417f17c0b495f0588235e SHA512 23939329c713a9ed47a5eac22f401c0cae01b150755dc167ea4ef6966c5a41354b7dce74ef0e3c5655c421e0444bca52f571d1e4ac821887f183f187e9318e11 WHIRLPOOL ccd2266521ba3e85f057a4acdaf32d08fa2a8aa552974611b51a0735fe23fe903ef39afa7fea89afba3706529e0fa6370454137538c0fbf03f8a05c1f65a134d
+DIST kopete-16.12.2.tar.xz 6339196 SHA256 2b0a73771f842998a2d39050367f89686409ac798592e5c191197acd9c5bc02d SHA512 fff8ab7e190b9f66f367c354f4ed75ba33653d7a7e4b42f577ca999a8c9c85f4cf09bb261b079b9d6e9108e3ef8ad9195305c82cfaeb8fe853c57236f4d30391 WHIRLPOOL 2d9905cd83e656723ce745c36685f34ffa75eb1d28e34e2ca83a4dc514f77a0cb6a4e5f70aeba72553880047c86c2343381cb7dcd95d23629dafe5d87b577ce5
diff --git a/kde-apps/kopete/kopete-16.12.2.ebuild b/kde-apps/kopete/kopete-16.12.2.ebuild
new file mode 100644
index 000000000000..655ab68cea9e
--- /dev/null
+++ b/kde-apps/kopete/kopete-16.12.2.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
+testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_kdeapps_dep kdepimlibs)
+ dev-libs/libpcre
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ kde-frameworks/kdelibs:4[zeroconf?]
+ media-libs/phonon[qt4]
+ media-libs/qimageblitz
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt4(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/libsrtp
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qjson
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+ winpopup? ( net-fs/samba )
+"
+DEPEND="${COMMONDEPEND}
+ jingle? ( dev-libs/jsoncpp )
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_GOOGLETALK=$(usex jingle)
+ -DWITH_LiboRTP=$(usex jingle)
+ -DWITH_Mediastreamer=$(usex jingle)
+ -DWITH_Speex=$(usex jingle)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ zeroconf) x2=bonjour ;;
+ xmpp) x2=jabber ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF -DWITH_sms=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then # || use irc; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}