summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 13:14:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 18:57:50 +0100
commit174572985ee44cc742471ec11e8d5780773c0e84 (patch)
treef30c2908c0cb19b6806acd5d3da61cbb1b8c045a /kde-apps/kopete
parentkde-apps/krfb: 20.08.3 version bump (diff)
downloadgentoo-174572985ee44cc742471ec11e8d5780773c0e84.tar.gz
gentoo-174572985ee44cc742471ec11e8d5780773c0e84.tar.bz2
gentoo-174572985ee44cc742471ec11e8d5780773c0e84.zip
kde-apps/kopete: 20.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-20.08.3.ebuild182
2 files changed, 183 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 9dd844b4c39b..d0814b2dc5d8 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-20.04.3.tar.xz 9371772 BLAKE2B 467a219dc6cc761c9ec2721138c13abc17ccfdd95e0021ad4f1625feb38517286967bf2df967dad009612623c9dd114f0e4bdb2c90292c0d9043a788131282eb SHA512 979f84c986f78aaab9bd23fb9e0df265ea8734d855b8370c93adbe037d6dfeb4271658dbd27c2b315b363731976a62750e2ed5dace45bc69e72c0645a533b5a0
DIST kopete-20.08.2.tar.xz 9385476 BLAKE2B f0f4022948aa9dde728bd2ccc30ea085bd6eb317d53d955f0acde6f30da5a9874e38db4245d8aa1329663a7f0cef7f793f549e72d38f6797e5235e5a8c607ed1 SHA512 deb514fe96d8092e58ef83a3529e8e7e7b44cc2a3900719b7977ca1040e2fa7357bde26c43a263dd183132d3c95041a5776e8f876212879c9b5d21e09a3fd663
+DIST kopete-20.08.3.tar.xz 9385476 BLAKE2B 5c465bd4d4408a396910697dbbbb87d64b826317d34c0d9e6fa1683df21b3cb02a605af32473fec5a50f87d0d22068cb90e66584c0ab1816410fa2c4c81db7cb SHA512 c888864c11ed108ca2f8b49b35d8354c6619ed5b9295be2680c89647ee78c76163f1c2b8aec8ee5effb8f0179d9539ced39094c603d41f9cbf4437919c1162b4
diff --git a/kde-apps/kopete/kopete-20.08.3.ebuild b/kde-apps/kopete/kopete-20.08.3.ebuild
new file mode 100644
index 000000000000..49f8a25f2b3f
--- /dev/null
+++ b/kde-apps/kopete/kopete-20.08.3.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.74.0
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/en/kopete"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="ssl v4l"
+
+# Available plugins
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: BROKEN (app-crypt/gpgme[cxx,qt5], kde-apps/libkleo:5)
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise meanwhile oscar testbed winpopup +xmpp zeroconf"
+
+# disabled protocols
+# irc: NO DEPS
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# skype, sms (until fixed)
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMON_DEPEND="
+ app-crypt/gpgme[cxx,qt5]
+ dev-libs/libpcre
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kemoticons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=media-libs/phonon-4.11.0
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( >=app-crypt/qca-2.3.0:2 )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ >=app-crypt/qca-2.3.0:2
+ net-dns/libidn:0=
+ sys-libs/zlib
+ )
+ zeroconf? (
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ )
+"
+# jingle? (
+# dev-libs/expat
+# dev-libs/openssl:0=
+# >=media-libs/mediastreamer-2.3.0
+# media-libs/speex
+# net-libs/libsrtp:0=
+# net-libs/ortp:=
+# )
+RDEPEND="${COMMON_DEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( >=app-crypt/qca-2.3.0:2[ssl] )
+"
+# sms? ( app-mobilephone/smssend )
+# winpopup? ( net-fs/samba )
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+# jingle? ( dev-libs/jsoncpp )
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_qq=OFF
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+# $(cmake_use_find_package jingle LiboRTP)
+# $(cmake_use_find_package jingle Mediastreamer)
+# $(cmake_use_find_package jingle Speex)
+
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}