summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-09 11:59:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-09 17:37:24 +0200
commit348809fd7c8977eade98e49f198554c4d5f45025 (patch)
tree1a1d444a0d5723c1256aad80ae6cc0af3685d284 /kde-apps/kopete
parentkde-apps/krfb: 20.04.3 version bump (diff)
downloadgentoo-348809fd7c8977eade98e49f198554c4d5f45025.tar.gz
gentoo-348809fd7c8977eade98e49f198554c4d5f45025.tar.bz2
gentoo-348809fd7c8977eade98e49f198554c4d5f45025.zip
kde-apps/kopete: 20.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-20.04.3.ebuild185
2 files changed, 186 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 2cdee07022d2..12bf8379ca5a 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-19.12.3.tar.xz 9376816 BLAKE2B 3a8d0e76a29370f8a9acc448ec961309281513305fb0461f8bda346bfa73f86847f29937c24effab727876b489b3d6c4d92c6078928a02b4e109118080c918fa SHA512 113aee174f2a7d85da69f9a877bdcfe2818433bcb545ae39dcaadce3b34a135edcb0f9a1dd0ed34901e2485388692a26b9d136eed1e7b63c097176d371da8e96
DIST kopete-20.04.2.tar.xz 9372040 BLAKE2B c244887c515701cb5c057cdb598a419421a779729d1f0f85205f444bd3603d553fbb244f03728a96c85131ae134f1ff431200435e81b4522b3817b08fc6ab8a9 SHA512 3281d865551b0a651f09f6abb9672f481e23ff4e6bfca498363d3bf92d1a1238b59e85f23a5b2febc5dc4c781a8db4aaa7ae4de335fc803abab12ba6a2975e53
+DIST kopete-20.04.3.tar.xz 9371772 BLAKE2B 467a219dc6cc761c9ec2721138c13abc17ccfdd95e0021ad4f1625feb38517286967bf2df967dad009612623c9dd114f0e4bdb2c90292c0d9043a788131282eb SHA512 979f84c986f78aaab9bd23fb9e0df265ea8734d855b8370c93adbe037d6dfeb4271658dbd27c2b315b363731976a62750e2ed5dace45bc69e72c0645a533b5a0
diff --git a/kde-apps/kopete/kopete-20.04.3.ebuild b/kde-apps/kopete/kopete-20.04.3.ebuild
new file mode 100644
index 000000000000..e971285b487f
--- /dev/null
+++ b/kde-apps/kopete/kopete-20.04.3.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.70.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Multi-protocol IM client based on KDE Frameworks"
+HOMEPAGE="https://kde.org/applications/internet/org.kde.kopete
+https://userbase.kde.org/Kopete"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="ssl v4l"
+
+# Available plugins
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: BROKEN (app-crypt/gpgme[cxx,qt5], kde-apps/libkleo:5)
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight history latex nowlistening
+otr pipes +privacy +statistics +texteffect translator +urlpicpreview webpresence"
+
+# Available protocols
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise meanwhile oscar testbed winpopup +xmpp zeroconf"
+
+# disabled protocols
+# irc: NO DEPS
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# skype, sms (until fixed)
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMON_DEPEND="
+ app-crypt/gpgme[cxx,qt5]
+ dev-libs/libpcre
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kemoticons-${KFMIN}:5
+ >=kde-frameworks/khtml-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ media-libs/phonon[qt5(+)]
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt5(+)] )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt5(+)]
+ net-dns/libidn:0=
+ sys-libs/zlib
+ )
+ zeroconf? (
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ )
+"
+# jingle? (
+# dev-libs/expat
+# dev-libs/openssl:0=
+# >=media-libs/mediastreamer-2.3.0
+# media-libs/speex
+# net-libs/libsrtp:0=
+# net-libs/ortp:=
+# )
+RDEPEND="${COMMON_DEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+"
+# sms? ( app-mobilephone/smssend )
+# winpopup? ( net-fs/samba )
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+# jingle? ( dev-libs/jsoncpp )
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_qq=OFF
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+# $(cmake_use_find_package jingle LiboRTP)
+# $(cmake_use_find_package jingle Mediastreamer)
+# $(cmake_use_find_package jingle Speex)
+
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ # disable until fixed:
+ mycmakeargs+=( -DWITH_{cryptography,libjingle,skype,sms}=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}