summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-07-14 08:53:59 +0200
committerJohannes Huber <johu@gentoo.org>2016-07-14 08:54:11 +0200
commitd75d62e86e94f72be5c0d39e70046e24310ff0ae (patch)
treeb05f1132b5224b3b1eef6b914e42d1204a4e9551 /kde-apps/kopete
parentkde5.eclass: Prepare for re-use of code w/ kde4-l10n (diff)
downloadgentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.tar.gz
gentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.tar.bz2
gentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.zip
kde-apps: Version bump KDE Applications 16.04.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-16.04.3.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 3a541e63ccd4..fa2c049adc5b 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-15.12.3.tar.xz 6327696 SHA256 c81de37fa01f03805e6209b14030b41aca00fa3ad14a3ff87dde6f3510351be5 SHA512 0fececf549d40974a70fe415bdd67d144d082364ceffc01907395abc4b30285487f1d117d7114911ea8a7e7f82a76724eb96d0b41fa791b1471332c2380c907d WHIRLPOOL c240c6d8aa20552f4f663d7858b0fcae53c82f780d0b8e4584565b1f27b55cbafaae9a728b9a1b2bb4b540cf8c9b6337d575a8d39e669799a1e9cbf18217daa6
DIST kopete-16.04.2.tar.xz 6329484 SHA256 ce0e6124aac67faba68817029ba3ef3193668be23bd5c748cdb8e608be91439a SHA512 52f1ff4b5186c45b7b209eda8df99474a46347f61841fdce3e6b9a43e9f394947f37dd08e52dbf07c116a7a470a985c47f678061cceadfd24e78aed48a8a1478 WHIRLPOOL 22a170c736f0778843667153f50dae06190f1180ad61f1683839d1cb2df1566c4512df8fc9e4035f73a8df995ab122b702f4a8fc38767fa47c8b452ec5269764
+DIST kopete-16.04.3.tar.xz 6328708 SHA256 e34625e2d2b10fe3a12a3a6b1a49a93c32daf96934ee3042538df409087c0abb SHA512 e830ace8ed364d333c72c46fb5ad29d549467afcf6f4563956341ba1651e5c5a91b1ba35a6388d5d428917cf9d086c3a9a0f5121c9bcfa492ec01b5f2c3b4e1b WHIRLPOOL d7b0faeada0f2127055d762032d9d0420bad3e119f1d857dca6590540c7eecab618add45da4b480d79cfbf518c8d1d96f445bd31344d4bf1b97e89509da8d95c
diff --git a/kde-apps/kopete/kopete-16.04.3.ebuild b/kde-apps/kopete/kopete-16.04.3.ebuild
new file mode 100644
index 000000000000..951fcca5d336
--- /dev/null
+++ b/kde-apps/kopete/kopete-16.04.3.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT=test
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
+sms testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kdelibs 'zeroconf?')
+ $(add_kdeapps_dep kdepimlibs)
+ dev-libs/libpcre
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ media-libs/phonon[qt4]
+ media-libs/qimageblitz
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt4(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/libsrtp
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )
+ sms? ( app-mobilephone/smssend )
+ ssl? ( app-crypt/qca:2[openssl] )
+ winpopup? ( net-fs/samba )
+"
+DEPEND="${COMMONDEPEND}
+ jingle? ( dev-libs/jsoncpp )
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_GOOGLETALK=$(usex jingle)
+ -DWITH_LiboRTP=$(usex jingle)
+ -DWITH_Mediastreamer=$(usex jingle)
+ -DWITH_Speex=$(usex jingle)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ zeroconf) x2=bonjour ;;
+ xmpp) x2=jabber ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then # || use irc; then
+ if ! has_version "app-crypt/qca:2[openssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=openssl."
+ fi
+ fi
+ fi
+}