summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/krfb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/krfb')
-rw-r--r--kde-apps/krfb/Manifest1
-rw-r--r--kde-apps/krfb/files/krfb-4.14.0-CVE-2014-4607-unbundle-libvncserver.patch133
-rw-r--r--kde-apps/krfb/krfb-4.14.3.ebuild44
-rw-r--r--kde-apps/krfb/metadata.xml9
4 files changed, 187 insertions, 0 deletions
diff --git a/kde-apps/krfb/Manifest b/kde-apps/krfb/Manifest
new file mode 100644
index 000000000000..a2921387d4d6
--- /dev/null
+++ b/kde-apps/krfb/Manifest
@@ -0,0 +1 @@
+DIST krfb-4.14.3.tar.xz 474604 SHA256 2d48831e15f457b85b0c41fbddde0575c680f50a78c974213f9d3aaa47e21723 SHA512 255a5d4ed364c071af7b2d23c707fd99cb68e6b45c6bb1a07558fad5b726cd7846f98751cbf71ae83df1dbc41e06a2dfd074f897660e732393bf95d1b217f7bb WHIRLPOOL 446f82a00345a59e48c79d358ba0b188e21d0325211cec304e7090b5333c65e3bb8d03474463e2148cd5c3f1c6da14e5fb7fd5ec90114b144667ef8c515bbdf0
diff --git a/kde-apps/krfb/files/krfb-4.14.0-CVE-2014-4607-unbundle-libvncserver.patch b/kde-apps/krfb/files/krfb-4.14.0-CVE-2014-4607-unbundle-libvncserver.patch
new file mode 100644
index 000000000000..202519b9f152
--- /dev/null
+++ b/kde-apps/krfb/files/krfb-4.14.0-CVE-2014-4607-unbundle-libvncserver.patch
@@ -0,0 +1,133 @@
+From 766fc7694a58b7e01c003356db94276f07b791b5 Mon Sep 17 00:00:00 2001
+From: Johannes Huber <johu@gentoo.org>
+Date: Thu, 31 Jul 2014 19:41:01 +0200
+Subject: [PATCH] CVE-2014-4607: Unbundle libvncserver
+
+http://seclists.org/oss-sec/2014/q2/676
+
+REVIEW: 119548
+---
+ CMakeLists.txt | 7 +++---
+ cmake/modules/FindLibVNCServer.cmake | 41 ++++++++++++++++++++++++++++++++++++
+ krfb/CMakeLists.txt | 2 ++
+ krfb/rfb.h | 2 +-
+ 4 files changed, 47 insertions(+), 5 deletions(-)
+ create mode 100644 cmake/modules/FindLibVNCServer.cmake
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4aa24dd..0b29da0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,6 +32,8 @@ set(CMAKE_MODULE_PATH
+ ${CMAKE_MODULE_PATH}
+ )
+
++find_package(LibVNCServer REQUIRED)
++
+ macro_optional_find_package(TelepathyQt4)
+ macro_log_feature(TelepathyQt4_FOUND "telepathy-qt" "Telepathy Qt Bindings" "http://telepathy.freedesktop.org" FALSE "0.9" "Needed to build Telepathy Tubes support.")
+
+@@ -44,8 +46,6 @@ macro_bool_to_01(X11_XShm_FOUND HAVE_XSHM)
+ include_directories ("${CMAKE_CURRENT_BINARY_DIR}/krfb"
+ "${CMAKE_CURRENT_SOURCE_DIR}/krfb"
+ "${CMAKE_CURRENT_SOURCE_DIR}/krfb/ui"
+- "${CMAKE_CURRENT_SOURCE_DIR}/libvncserver/"
+- "${CMAKE_CURRENT_BINARY_DIR}/libvncserver/"
+ )
+
+ if(Q_WS_X11)
+@@ -54,9 +54,8 @@ if(Q_WS_X11)
+ endif(NOT X11_XTest_FOUND)
+ endif(Q_WS_X11)
+
+-add_subdirectory(libvncserver)
+ add_subdirectory(krfb)
+-add_subdirectory (framebuffers)
++add_subdirectory(framebuffers)
+ add_subdirectory(doc)
+
+ if (NOT INSIDE_KDENETWORK)
+diff --git a/cmake/modules/FindLibVNCServer.cmake b/cmake/modules/FindLibVNCServer.cmake
+new file mode 100644
+index 0000000..5927ab2
+--- /dev/null
++++ b/cmake/modules/FindLibVNCServer.cmake
+@@ -0,0 +1,41 @@
++# cmake macro to test LIBVNCSERVER LIB
++
++# Copyright (c) 2006, Alessandro Praduroux <pradu@pradu.it>
++# Copyright (c) 2007, Urs Wolfer <uwolfer @ kde.org>
++#
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
++
++INCLUDE(CheckPointerMember)
++
++IF (LIBVNCSERVER_INCLUDE_DIR AND LIBVNCSERVER_LIBRARIES)
++ # Already in cache, be silent
++ SET(LIBVNCSERVER_FIND_QUIETLY TRUE)
++ENDIF (LIBVNCSERVER_INCLUDE_DIR AND LIBVNCSERVER_LIBRARIES)
++
++FIND_PATH(LIBVNCSERVER_INCLUDE_DIR rfb/rfb.h)
++
++FIND_LIBRARY(LIBVNCSERVER_LIBRARIES NAMES vncserver libvncserver)
++
++# libvncserver and libvncclient are in the same package, so it does
++# not make sense to add a new cmake script for finding libvncclient.
++# instead just find the libvncclient also in this file.
++FIND_PATH(LIBVNCCLIENT_INCLUDE_DIR rfb/rfbclient.h)
++FIND_LIBRARY(LIBVNCCLIENT_LIBRARIES NAMES vncclient libvncclient)
++
++IF (LIBVNCSERVER_INCLUDE_DIR AND LIBVNCSERVER_LIBRARIES)
++ SET(CMAKE_REQUIRED_INCLUDES "${LIBVNCSERVER_INCLUDE_DIR}" "${CMAKE_REQUIRED_INCLUDES}")
++ CHECK_POINTER_MEMBER(rfbClient* GotXCutText rfb/rfbclient.h LIBVNCSERVER_FOUND)
++ENDIF (LIBVNCSERVER_INCLUDE_DIR AND LIBVNCSERVER_LIBRARIES)
++
++IF (LIBVNCSERVER_FOUND)
++ IF (NOT LIBVNCSERVER_FIND_QUIETLY)
++ MESSAGE(STATUS "Found LibVNCServer: ${LIBVNCSERVER_LIBRARIES}")
++ ENDIF (NOT LIBVNCSERVER_FIND_QUIETLY)
++ELSE (LIBVNCSERVER_FOUND)
++ IF (LIBVNCSERVER_FIND_REQUIRED)
++ MESSAGE(FATAL_ERROR "Could NOT find acceptable version of LibVNCServer (version 0.9 or later required).")
++ ENDIF (LIBVNCSERVER_FIND_REQUIRED)
++ENDIF (LIBVNCSERVER_FOUND)
++
++MARK_AS_ADVANCED(LIBVNCSERVER_INCLUDE_DIR LIBVNCSERVER_LIBRARIES)
+\ No newline at end of file
+diff --git a/krfb/CMakeLists.txt b/krfb/CMakeLists.txt
+index a65eea8..100b49b 100644
+--- a/krfb/CMakeLists.txt
++++ b/krfb/CMakeLists.txt
+@@ -20,6 +20,7 @@ target_link_libraries (krfbprivate
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${X11_X11_LIB}
++ ${LIBVNCSERVER_LIBRARIES}
+ )
+
+ set_target_properties (krfbprivate PROPERTIES
+@@ -103,6 +104,7 @@ target_link_libraries (krfb
+ ${QT_QTNETWORK_LIBRARY}
+ ${KDE4_KDNSSD_LIBS}
+ ${KDE4_KDEUI_LIBS}
++ ${LIBVNCSERVER_LIBRARIES}
+ )
+
+ if(TelepathyQt4_FOUND)
+diff --git a/krfb/rfb.h b/krfb/rfb.h
+index 40308a2..fa94eda 100644
+--- a/krfb/rfb.h
++++ b/krfb/rfb.h
+@@ -6,7 +6,7 @@
+ #ifndef KRFB_RFB_H
+ #define KRFB_RFB_H
+
+-#include "../libvncserver/rfb/rfb.h"
++#include "rfb/rfb.h"
+
+ #undef TRUE
+ #undef FALSE
+--
+2.0.2
+
diff --git a/kde-apps/krfb/krfb-4.14.3.ebuild b/kde-apps/krfb/krfb-4.14.3.ebuild
new file mode 100644
index 000000000000..9f0c70a66503
--- /dev/null
+++ b/kde-apps/krfb/krfb-4.14.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="VNC-compatible server to share KDE desktops"
+HOMEPAGE="http://www.kde.org/applications/system/krfb/"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug telepathy ktp"
+REQUIRED_USE="ktp? ( telepathy )"
+
+DEPEND="
+ >=net-libs/libvncserver-0.9.9
+ sys-libs/zlib
+ virtual/jpeg:0
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXtst
+ )
+ telepathy? ( >=net-libs/telepathy-qt-0.9 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # bug 518824, patch before eclass magic
+ epatch "${FILESDIR}/${PN}-4.14.0-CVE-2014-4607-unbundle-libvncserver.patch"
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with telepathy TelepathyQt4)
+ $(cmake-utils_use_with ktp KTp)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/krfb/metadata.xml b/kde-apps/krfb/metadata.xml
new file mode 100644
index 000000000000..5da474c874c3
--- /dev/null
+++ b/kde-apps/krfb/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="telepathy">Enable desktop sharing through a telepathy client</flag>
+ <flag name="ktp">Enable displaying of KDE Telepathy contacts</flag>
+ </use>
+</pkgmetadata>