summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-11-20 01:01:35 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-11-22 05:46:11 +1100
commitc15a6d88a1709f6a71dafae9a105b5c39c32db3b (patch)
tree3314216bd759eb677cefa1802626c26b9bce77c6 /kde-apps/ksystemlog/ksystemlog-15.08.3.ebuild
parentkde-apps: Drop KDE Applications 15.08.1 (diff)
downloadgentoo-c15a6d88a1709f6a71dafae9a105b5c39c32db3b.tar.gz
gentoo-c15a6d88a1709f6a71dafae9a105b5c39c32db3b.tar.bz2
gentoo-c15a6d88a1709f6a71dafae9a105b5c39c32db3b.zip
kde-apps: Bump existing ebuilds to 15.08.3 from overlay
Diffstat (limited to 'kde-apps/ksystemlog/ksystemlog-15.08.3.ebuild')
-rw-r--r--kde-apps/ksystemlog/ksystemlog-15.08.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/ksystemlog-15.08.3.ebuild b/kde-apps/ksystemlog/ksystemlog-15.08.3.ebuild
new file mode 100644
index 000000000000..a935bcd3f21f
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-15.08.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}