summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-03-02 02:17:56 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-03-02 03:37:33 +1100
commit3abbf68918a6bb8e4e42f1a2e676fc0eca88cd51 (patch)
treebccb80395a88e58d70bb79a1cbf3cd53b2e83d1a /kde-apps/ksystemlog/ksystemlog-15.12.2.ebuild
parentmedia-sound/easytag: Removed old. (diff)
downloadgentoo-3abbf68918a6bb8e4e42f1a2e676fc0eca88cd51.tar.gz
gentoo-3abbf68918a6bb8e4e42f1a2e676fc0eca88cd51.tar.bz2
gentoo-3abbf68918a6bb8e4e42f1a2e676fc0eca88cd51.zip
kde-apps: version bump kdeadmin 15.12.2
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/ksystemlog/ksystemlog-15.12.2.ebuild')
-rw-r--r--kde-apps/ksystemlog/ksystemlog-15.12.2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/ksystemlog-15.12.2.ebuild b/kde-apps/ksystemlog/ksystemlog-15.12.2.ebuild
new file mode 100644
index 000000000000..bfc62e9e3492
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-15.12.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_DOXYGEN="true"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT=test
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}