summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-10-18 21:57:11 +0200
committerJohannes Huber <johu@gentoo.org>2016-10-18 22:09:22 +0200
commit8a5934aa38e64c3560752baff5c9c7b03eff2981 (patch)
tree751c477265fbf6365b06564fc5b25aad11b2f91e /kde-apps/ksystemlog
parentprofiles: Update KDE PIM 16.08 mask (diff)
downloadgentoo-8a5934aa38e64c3560752baff5c9c7b03eff2981.tar.gz
gentoo-8a5934aa38e64c3560752baff5c9c7b03eff2981.tar.bz2
gentoo-8a5934aa38e64c3560752baff5c9c7b03eff2981.zip
kde-apps: Version bump KDE Applications 16.08.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-apps/ksystemlog')
-rw-r--r--kde-apps/ksystemlog/Manifest1
-rw-r--r--kde-apps/ksystemlog/ksystemlog-16.08.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/Manifest b/kde-apps/ksystemlog/Manifest
index f3c195eefe16..27b4ae4041ea 100644
--- a/kde-apps/ksystemlog/Manifest
+++ b/kde-apps/ksystemlog/Manifest
@@ -1,2 +1,3 @@
DIST ksystemlog-16.04.3.tar.xz 395644 SHA256 3bc1571e8aae59ae7738aa1ff3b2d363895a359711363f18e4bf20c9172df9bb SHA512 8e3d77f55b0f541af50bae0ecdefeca08bf35ffcf89474acaa0677c1bd153b23eb57e03b27238e9e7d5465b04a578da04c801712e6adc1588cfd9a507b9e2617 WHIRLPOOL 9167723cd59d5994a8b68f21fb0881d9aa6e1433226ec30dea2b111ae3812555181431b81c88beb940f4859ad48c36507443d02683759ffa2ec643921f94ff26
DIST ksystemlog-16.08.1.tar.xz 350312 SHA256 e953e4b9e5e3790aab99b99f499bc346e5fe30e6633f23889185b5ff34ef593d SHA512 7a9917652fa72aa11a5b71528da8ed7f3b3bf16be841d0c40ea52da7f78d8a4c279319c132ce68bdcfdde75b8cbc2888303418b706cb516f284ed81bd622324f WHIRLPOOL f96b71c57b3e468dd04d9b3578cb46b9a139476ec7b6c9004b2c723332039c0929d812fe5d7f676201cd2da8d5e8acadb18704e38e5b97225dbc8cf998aebe91
+DIST ksystemlog-16.08.2.tar.xz 350284 SHA256 cb239ecf4964046d85504a1e48e63db8357cca2442abec6f63f298c3205b870a SHA512 2f56d32a82e802b1d7cdb53b9b18ceeb657cba50de553fe826bfe106000fb7670fd8e23cdbf33cefb989c1ddaf61bd0c14d8584ad73b452bc5dad3865698c4b4 WHIRLPOOL 29951491b731dc6234a5a1298fa67d825dafed32e7a486e136503bc0d3c2b3397ac5c4d756544844979ee71ba760dbc7a45063cda945b23b9e9d8c7bb3a48415
diff --git a/kde-apps/ksystemlog/ksystemlog-16.08.2.ebuild b/kde-apps/ksystemlog/ksystemlog-16.08.2.ebuild
new file mode 100644
index 000000000000..528c3edca98c
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-16.08.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT=test
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}