summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:34:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:36:38 +0100
commitc1941078fbe8744f0710332dee5705d3a95a800b (patch)
tree2fbace875e510011c2845a85071b60cf371926d5 /kde-apps/ksystemlog
parentapp-emulation/xen-tools: drop old (diff)
downloadgentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.gz
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.bz2
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.zip
kde-apps: Add KDE Applications 18.12.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-apps/ksystemlog')
-rw-r--r--kde-apps/ksystemlog/Manifest1
-rw-r--r--kde-apps/ksystemlog/ksystemlog-18.12.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/Manifest b/kde-apps/ksystemlog/Manifest
index 043de9c8f959..dcafac9e375b 100644
--- a/kde-apps/ksystemlog/Manifest
+++ b/kde-apps/ksystemlog/Manifest
@@ -1,2 +1,3 @@
DIST ksystemlog-18.08.3.tar.xz 1966776 BLAKE2B f6715026b009296856c9120b0236b4efff681d1cd02d7694db8dde3d8df7a521c0640540ee3b1cfd69d1cf8bf8a6976773a217dcfcacbde5f4aaeb2689786fe9 SHA512 0cdf798c3d6c51851fd3cc2eda04e445a413459ee29d7b98d799a749d21a6a80447bce37651ac22e4b652fc10452dc2fb6408108cce2a968e7fc7f2379b0c915
DIST ksystemlog-18.12.2.tar.xz 1924272 BLAKE2B d6b4eaa49eddc597b790437da9501f0929d85c2017a956cafb674bb0f1a01912031de2b044426f56eb299818932bbe3723619627d0329ae607169a37a344585d SHA512 4eb98902462b661e5351ecd65f93c723d4d6d96215cda3de87dde26af9f8acd1086776f95466a9cace97314c781e18e62c93d31721e0a1fe5156a7ba2e52c95e
+DIST ksystemlog-18.12.3.tar.xz 1924336 BLAKE2B a115fbb7be2137fe3ec1073185dd25d5fbe97facb228e066471829c4feaab82550f00ee1454f689d511d91c76e5455643544bf7b7f3c04d3d06be497e015f475 SHA512 4808d8981e5d7d5d75be11c3b00c25e4962ea2b8a5e600f50aff2ca8e74d9af924859329224c92001a91e9fa697fae29a21c2ed1209cada641c732773b2bad0b
diff --git a/kde-apps/ksystemlog/ksystemlog-18.12.3.ebuild b/kde-apps/ksystemlog/ksystemlog-18.12.3.ebuild
new file mode 100644
index 000000000000..fc6ee72916b2
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-18.12.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp || die
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" \
+ -i ksystemlog/tests/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}