summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-21 15:39:01 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-21 15:39:45 +0200
commit5e10890b6ebfc31a933ac5829dfad6f723ee0aff (patch)
treea683bc38a6a1d3c0a463b5a2e4d45c87388c01ac /kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-15.12.3.ebuild
parentprofiles: Mask kde-apps/ktp-text-ui[speech] (diff)
downloadgentoo-5e10890b6ebfc31a933ac5829dfad6f723ee0aff.tar.gz
gentoo-5e10890b6ebfc31a933ac5829dfad6f723ee0aff.tar.bz2
gentoo-5e10890b6ebfc31a933ac5829dfad6f723ee0aff.zip
kde-apps: Add Plasma Telepathy client 15.12.3
Gentoo-bug: 579258 Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-15.12.3.ebuild')
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-15.12.3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-15.12.3.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-15.12.3.ebuild
new file mode 100644
index 000000000000..bc992095bf54
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-15.12.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+ !net-im/ktp-accounts-kcm
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+}