summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-13 15:55:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-13 15:58:19 +0100
commitff68a61d7cd4786f56bed62410f9206e588e8d8e (patch)
tree69313c252a0aed267809ad3a0d7f31c5c10177a3 /kde-apps/ktp-accounts-kcm
parentdev-php/pecl-yaz: amd64 stable wrt bug #667068 (diff)
downloadgentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.tar.gz
gentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.tar.bz2
gentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.zip
kde-apps: Add KDE Applications 18.12.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-accounts-kcm')
-rw-r--r--kde-apps/ktp-accounts-kcm/Manifest1
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.12.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/Manifest b/kde-apps/ktp-accounts-kcm/Manifest
index e02a914fb8a2..7073d02da6f0 100644
--- a/kde-apps/ktp-accounts-kcm/Manifest
+++ b/kde-apps/ktp-accounts-kcm/Manifest
@@ -1 +1,2 @@
DIST ktp-accounts-kcm-18.08.3.tar.xz 264276 BLAKE2B 437b13856295370b630341f0dc7b0d2cf547026a6ac73794861aa4ad9ec87eee00df26162c07f920817743c50bef34e71e28092797058adbc8cf887bd894465b SHA512 76ceadf72dc1dc6e9265fb5976e4123e20863fa470cc1dc1c1537a1ba664699b69e9e3b1ff88708859d194b9033ae963e619b1f571e680d1ef758bbe63ce8d98
+DIST ktp-accounts-kcm-18.12.0.tar.xz 261664 BLAKE2B 717e104fed7c25b143a32577282f5f1e928cc4d329c257a8dfb66abb2fa5e8e75c076fd75e53d0eefaa3906b6de849fb8962417e6640f91c2f19418b3c086f5a SHA512 ca94dc40d360f89c650c369c5c3b4dc3ddd99965085298b37c7e61a2a4f816ae944e94afb60b17954d3f7ece9ff75cd9bd782ea4ef1c84765dd2256d4c432f82
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.12.0.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.12.0.ebuild
new file mode 100644
index 000000000000..3aef765d210e
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.12.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ dev-util/intltool
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+}