summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-07-14 08:53:59 +0200
committerJohannes Huber <johu@gentoo.org>2016-07-14 08:54:11 +0200
commitd75d62e86e94f72be5c0d39e70046e24310ff0ae (patch)
treeb05f1132b5224b3b1eef6b914e42d1204a4e9551 /kde-apps/ktp-auth-handler/ktp-auth-handler-16.04.3.ebuild
parentkde5.eclass: Prepare for re-use of code w/ kde4-l10n (diff)
downloadgentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.tar.gz
gentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.tar.bz2
gentoo-d75d62e86e94f72be5c0d39e70046e24310ff0ae.zip
kde-apps: Version bump KDE Applications 16.04.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/ktp-auth-handler/ktp-auth-handler-16.04.3.ebuild')
-rw-r--r--kde-apps/ktp-auth-handler/ktp-auth-handler-16.04.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/ktp-auth-handler/ktp-auth-handler-16.04.3.ebuild b/kde-apps/ktp-auth-handler/ktp-auth-handler-16.04.3.ebuild
new file mode 100644
index 000000000000..252e8a6ca288
--- /dev/null
+++ b/kde-apps/ktp-auth-handler/ktp-auth-handler-16.04.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy authentication handler"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ app-crypt/qca:2[qt5]
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kdewebkit)
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[openssl]
+ !kde-apps/ktp-auth-handler:4
+"