summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-08-25 06:38:45 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-08-25 20:46:59 +1000
commit37150fa963eb3aa155eb9e94c3d6b233154ca1de (patch)
tree8bce549e96d6e85c58e00d1b3cbd303869107118 /kde-apps/ktp-l10n/ktp-l10n-15.12.3.ebuild
parentmedia-libs/libart_lgpl: eapi bump, fix src_install phase (and, then, really d... (diff)
downloadgentoo-37150fa963eb3aa155eb9e94c3d6b233154ca1de.tar.gz
gentoo-37150fa963eb3aa155eb9e94c3d6b233154ca1de.tar.bz2
gentoo-37150fa963eb3aa155eb9e94c3d6b233154ca1de.zip
kde-apps: remove 15.12.3
Diffstat (limited to 'kde-apps/ktp-l10n/ktp-l10n-15.12.3.ebuild')
-rw-r--r--kde-apps/ktp-l10n/ktp-l10n-15.12.3.ebuild135
1 files changed, 0 insertions, 135 deletions
diff --git a/kde-apps/ktp-l10n/ktp-l10n-15.12.3.ebuild b/kde-apps/ktp-l10n/ktp-l10n-15.12.3.ebuild
deleted file mode 100644
index 7cc85eb820c3..000000000000
--- a/kde-apps/ktp-l10n/ktp-l10n-15.12.3.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-KDE_HANDBOOK="false"
-inherit kde5
-
-DESCRIPTION="KDE Telepathy internationalization package"
-HOMEPAGE="http://l10n.kde.org"
-
-DEPEND="
- $(add_frameworks_dep ki18n)
- $(add_qt_dep linguist-tools)
- sys-devel/gettext
-"
-RDEPEND="
- !<kde-apps/kde-l10n-15.08.0-r1
- !kde-apps/ktp-accounts-kcm:4
- !kde-apps/ktp-approver:4
- !kde-apps/ktp-auth-handler:4
- !kde-apps/ktp-common-internals:4
- !kde-apps/ktp-contact-list:4
- !kde-apps/ktp-filetransfer-handler:4
- !kde-apps/ktp-kded-module:4
- !kde-apps/ktp-send-file:4
- !kde-apps/ktp-text-ui:4
-"
-
-KEYWORDS="amd64 x86"
-IUSE=""
-
-# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.xz::' -e 's:kde-l10n-::' |tr '\n' ' '
-MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
-he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru
-sk sl sr sv tr ug uk wa zh_CN zh_TW"
-
-PIM_L10N="kdepim kdepimlibs kdepim-runtime pim"
-
-URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
-SRC_URI=""
-
-for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
- SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE/ktp/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
-done
-
-S="${WORKDIR}"
-
-src_unpack() {
- if [[ -z ${A} ]]; then
- elog
- elog "None of the requested L10N are supported by ${P}."
- elog
- elog "${P} supports these language codes:"
- elog "${MY_LANGS//[@_]/-}"
- elog
- fi
-
- [[ -n ${A} ]] && unpack ${A}
-}
-
-src_prepare() {
- default
-
- local LNG DIR
- # add all l10n to cmake
- if [[ -n ${A} ]]; then
- for LNG in ${MY_LANGS}; do
- DIR="kde-l10n-${LNG}-${PV}"
- SDIR="${S}/${DIR}/5/${LNG}"
- if [[ -d "${DIR}" ]] ; then
- echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
-
- # Drop KDE4-based part
- sed -e '/add_subdirectory(4)/ s/^/#/'\
- -i "${S}"/${DIR}/CMakeLists.txt || die
-
- # We only want messages
- sed -e '/messages/!s/^add_subdirectory/# DONT/'\
- -i "${SDIR}"/CMakeLists.txt || die
- sed -e '/KF5DocTools/ s/^/#/'\
- -i "${SDIR}"/CMakeLists.txt || die
-
- # Remove everything except kdenetwork
- if [[ -d "${SDIR}/messages" ]] ; then
- echo > "${SDIR}/messages/CMakeLists.txt"
- [[ -d "${SDIR}/messages/kdenetwork" ]] && \
- ( echo "add_subdirectory(kdenetwork)" >> "${SDIR}/messages/CMakeLists.txt" )
- # Remove everything but ktp translations
- find "${SDIR}"/messages/kdenetwork -type f ! \( -name CMakeLists.txt \
- -o -name kaccounts*po -o -name kcm_ktp*po -o -name kcmtelepathy*po \
- -o -name kded_ktp*po -o -name ktp*po -o -name plasma*ktp*po \) \
- -delete
- fi
-
- # In some cases we may have sub-lingua subdirs, e.g. sr :(
- for XSUBDIR in "${SDIR}/${LNG}"@* ; do
- XLNG=$(echo ${XSUBDIR}|sed -e 's:^.*/::')
- if [[ -d "${XSUBDIR}" ]] ; then
- einfo " ${XLNG} variant"
- # remove everything except kdenetwork
- if [[ -d "${XSUBDIR}/messages" ]] ; then
- echo > "${XSUBDIR}/messages/CMakeLists.txt"
- [[ -d "${XSUBDIR}/messages/kdenetwork" ]] && \
- ( echo "add_subdirectory(kdenetwork)" >> "${XSUBDIR}/messages/CMakeLists.txt" )
- # Remove everything but ktp translations
- find "${XSUBDIR}"/messages/kdenetwork -type f ! \( -name CMakeLists.txt \
- -o -name kaccounts*po -o -name kcm_ktp*po -o -name kcmtelepathy*po \
- -o -name kded_ktp*po -o -name ktp*po -o -name plasma*ktp*po \) \
- -delete
- fi
- fi
- done
- fi
- done
- fi
-}
-
-src_configure() {
- [[ -n ${A} ]] && kde5_src_configure
-}
-
-src_compile() {
- [[ -n ${A} ]] && kde5_src_compile
-}
-
-src_test() {
- [[ -n ${A} ]] && kde5_src_test
-}
-
-src_install() {
- [[ -n ${A} ]] && kde5_src_install
-}