summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-04-20 18:15:02 +0200
committerJohannes Huber <johu@gentoo.org>2017-04-20 18:22:40 +0200
commit8f00b2bf566d896205f52099530159c97b977f68 (patch)
tree6dfeae9f7a9dc7b276cb384a7f4ad8d589de52d1 /kde-apps/ktp-text-ui
parentkde5*eclass: KDE Applications 17.04.0 improvements (diff)
downloadgentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.gz
gentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.bz2
gentoo-8f00b2bf566d896205f52099530159c97b977f68.zip
kde-apps: Version bump KDE Applications 17.04.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'kde-apps/ktp-text-ui')
-rw-r--r--kde-apps/ktp-text-ui/Manifest1
-rw-r--r--kde-apps/ktp-text-ui/ktp-text-ui-17.04.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-apps/ktp-text-ui/Manifest b/kde-apps/ktp-text-ui/Manifest
index 2e0afbf41e57..989c97f57cd2 100644
--- a/kde-apps/ktp-text-ui/Manifest
+++ b/kde-apps/ktp-text-ui/Manifest
@@ -1 +1,2 @@
DIST ktp-text-ui-16.12.3.tar.xz 295608 SHA256 33c02e1cb5b9b49ab6fe6bdbeb0ae9baacfd67febc4b7fafbd5762b6cbc85d6b SHA512 a416e70876f1f437fda695f6d66f69264ecd255699e73127b403cdf4294dee09bc1708178b15e988331fdbc555cf9e5bf484b18cf206a3555362eda3148862d9 WHIRLPOOL 1e69279e91181123dddde1f4a2166f17ddc5583b1859e54b1adafb84364646dcff631e622d01dc9363ce1555fa96b69dcd110e41dabedbc68cdf49b9f598970e
+DIST ktp-text-ui-17.04.0.tar.xz 467332 SHA256 8a4f7671b6fc711d8fcdcf3f5a0df9ab0f5e4d4cdb3f226c9f9e33369607d4a3 SHA512 32c1bc0f31b3aa235c89cdbc48bddbb092c1e80230bfd3e2d336e5102666168c96159dd58c2865cea4b371cb607c70ad20f822cc3450772bcc0205ae8e8388e7 WHIRLPOOL a3d7f82b1870052704a35558075ff0ce599fa7e25fcb1fc47419937911a0ec819ce2010445b50de4b0ec540160cb80e76116330bff70ef6f59370a54159c0052
diff --git a/kde-apps/ktp-text-ui/ktp-text-ui-17.04.0.ebuild b/kde-apps/ktp-text-ui/ktp-text-ui-17.04.0.ebuild
new file mode 100644
index 000000000000..209e84ed325b
--- /dev/null
+++ b/kde-apps/ktp-text-ui/ktp-text-ui-17.04.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+QT_MINIMAL="5.7.1"
+inherit kde5
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="Apache-2.0 || ( AFL-2.1 BSD ) GPL-2+ LGPL-2.1+ MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_kdeapps_dep ktp-common-internals otr)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ net-libs/telepathy-qt[qt5]
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep ktp-contact-list)
+ !kde-apps/ktp-text-ui:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}