summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/mailcommon
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/mailcommon')
-rw-r--r--kde-apps/mailcommon/Manifest1
-rw-r--r--kde-apps/mailcommon/mailcommon-19.08.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/mailcommon/Manifest b/kde-apps/mailcommon/Manifest
index cefafca730c4..7a14dd6cf103 100644
--- a/kde-apps/mailcommon/Manifest
+++ b/kde-apps/mailcommon/Manifest
@@ -1 +1,2 @@
+DIST mailcommon-19.08.3.tar.xz 693672 BLAKE2B 2be6b716903e83a8e9397a24d8f062b65180e39fef1b0d784804a9bb09a1760d66a2099c331da6456c3bac7654d91c238acc3275961fbd4234afdc11c8784470 SHA512 d1bf8aea689f0cb24dc2030c258795465b3a5e5c16bb49a2f35f62b999faf97cb40f0dd3d4e2bd2d6033e48438bc693fddcfa69d34ad799f4fb22d808f9b06ff
DIST mailcommon-19.12.3.tar.xz 700376 BLAKE2B 2ee65d731290740288fceb72b186ff132fc66b6a6022bb112960a35597e81172dd0c0edc030e851b85c6a0d9ba2cc9f6901b6356cd55f5332dd169a51c20d116 SHA512 3f7cea9ff5f7a649f58d0c1e8404f2d9df0557e54ccb2806eb556a5ebdd3c06e2f50fe06d1916faef836f2b9c192baa958991d733523b6cb85e8f428b9663161
diff --git a/kde-apps/mailcommon/mailcommon-19.08.3.ebuild b/kde-apps/mailcommon/mailcommon-19.08.3.ebuild
new file mode 100644
index 000000000000..24ecba949df4
--- /dev/null
+++ b/kde-apps/mailcommon/mailcommon-19.08.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Common mail library"
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="arm64"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+BDEPEND="
+ dev-libs/libxslt
+"
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailimporter-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ >=dev-qt/qtxml-${QTMIN}:5
+ media-libs/phonon[qt5(+)]
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+RESTRICT+=" test"