summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:10:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:11:17 +0200
commitcace445d5118ee027dc43f829fc50f27d623134c (patch)
tree2dfaad77bd443bf2f28d49d3bcf8c2880aa92ff3 /kde-apps/pimcommon
parentdev-util/rbtools: maintainer-needed (diff)
downloadgentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.gz
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.bz2
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.zip
kde-apps: Add KDE Applications 19.08.1
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-19.08.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index 53de7d2e178e..6817d7661092 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-19.04.3.tar.xz 294420 BLAKE2B 87d67b7dd975b0d989b5ca408e478cfed68918b1451f5faf16538d5fdd5033c00b1b98b07c8b75183ee83b21fa929aed94473a2935075886ff78db85c1589881 SHA512 862d240de0b551035eddf03cbbfe381c7a11c0715e4a0159447197525e5f68cf62ddc716726e1229f5be9e99c6c5129db8ed87aa8e8d0b713a23698a81884f27
DIST pimcommon-19.08.0.tar.xz 292816 BLAKE2B aa502bcf04ed42d3c042a3f26a4b81b2802d01726c80d96e087928b393a9a72fd630e695919158ebe0c3e536fb2bf3271e87a52e530f741dde1533072af4fbb2 SHA512 aeb8082f41c1ebdf8f649a03e97d777b5e8f2c1f3dab0ca7d8c70ade4356ab47c2d47debec451320d895fa1ae6059e3b160fe293af27502104d9ec1769df8469
+DIST pimcommon-19.08.1.tar.xz 293872 BLAKE2B c48ef7304fdc3e172bf68d885d7ce9aba3ec9f38ba5dec17ac03dd4e636cc165cdfa3dcb6e2ca36e840c4c489757df17a8924d74d57882f21ea71ed3debae1d6 SHA512 bd32b3d7cbd0dcd3f539037c92227df655874b296ed1d7501255ce470b2a8692d53bf0848a765bf901f173d36f7b580cddcdf4a33f1c903a5280f1a99184846f
diff --git a/kde-apps/pimcommon/pimcommon-19.08.1.ebuild b/kde-apps/pimcommon/pimcommon-19.08.1.ebuild
new file mode 100644
index 000000000000..89a6b4577fc9
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-19.08.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep purpose)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ test? ( $(add_kdeapps_dep kmime) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ kde5_src_test
+}