summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-18 15:42:18 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-18 16:03:33 +0200
commit66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd (patch)
tree5096e0b3a3b9501276d23ccbdefa39f613d758d5 /kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.04.1.ebuild
parentapp-misc/tmux: Add 2.1-r1 and ship terminfo file. (diff)
downloadgentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.tar.gz
gentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.tar.bz2
gentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.zip
kde-apps: Version bump KDE Applications 16.04.1
Except KDE PIM which is not ready for production yet, which is available (masked) in kde overlay. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.04.1.ebuild')
-rw-r--r--kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.04.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.04.1.ebuild b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.04.1.ebuild
new file mode 100644
index 000000000000..7bde3ba5b12f
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.04.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5-meta-pkg
+
+DESCRIPTION="Plasma Telepathy client"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer nls"
+
+[[ ${KDE_BUILD_TYPE} = live ]] && L10N_MINIMAL=${KDE_APPS_MINIMAL}
+
+RDEPEND="
+ $(add_kdeapps_dep ktp-accounts-kcm)
+ $(add_kdeapps_dep ktp-approver)
+ $(add_kdeapps_dep ktp-auth-handler)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_kdeapps_dep ktp-contact-list)
+ $(add_kdeapps_dep ktp-contact-runner)
+ $(add_kdeapps_dep ktp-desktop-applets)
+ $(add_kdeapps_dep ktp-filetransfer-handler)
+ $(add_kdeapps_dep ktp-kded-module)
+ $(add_kdeapps_dep ktp-send-file)
+ $(add_kdeapps_dep ktp-text-ui)
+ !kde-apps/plasma-telepathy-meta:4
+ gstreamer? ( $(add_kdeapps_dep ktp-call-ui) )
+ nls? ( $(add_kdeapps_dep ktp-l10n '' ${L10N_MINIMAL}) )
+"
+
+pkg_postinst() {
+ echo
+ elog "You can configure the accounts in Plasma System Settings"
+ elog "and then add the Instant Messaging plasma applet to access the contact list."
+ echo
+}