summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-09-15 21:33:27 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-09-15 21:38:26 +1000
commit5bc2531e9317b8679cc9e1ae68ee5883518bb613 (patch)
tree29fde51ed18962fcd1f1c5cf98f58ba728bc67f7 /kde-apps/print-manager
parentprofiles: mask >=kde-apps/minuet-16.08.0 as it requires masked Qt 5.7 (diff)
downloadgentoo-5bc2531e9317b8679cc9e1ae68ee5883518bb613.tar.gz
gentoo-5bc2531e9317b8679cc9e1ae68ee5883518bb613.tar.bz2
gentoo-5bc2531e9317b8679cc9e1ae68ee5883518bb613.zip
kde-apps: version bump 16.08.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-16.08.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index b9b52a015888..ce10e1af24e9 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-16.04.3.tar.xz 94100 SHA256 9c577a0efa86e5eb9ea151ba1b1a7ad23949130c10b5046f6590399aa9aa04ce SHA512 92c5bf28ed4d85519c0eacd5baf8de29d516caaa823f96a51e7cd4f87bebef4c62372eee4ea1c62cbffc4e2b04c9264f4418dadbe674810026bf70dff5226370 WHIRLPOOL 24209380025f8341c9a70a12687958aa93fabf952f2e99decdd07c458aeb5da5ba08d1178ee26bf51ffabbfdc460285bdf680641248d92a95a6c5413b6d914bf
+DIST print-manager-16.08.1.tar.xz 94136 SHA256 b83013c260fa0843717ba44925949869d03678d9e6f431e3151ec56c0a9f0eda SHA512 7f1f84f908e732d58f8bbc478b02ca0a8e7a93a6daf71dd6a14a1727da7df6810cde01770f15bf63535c741142f55c32e2ea96321de068f0e66deee4543d5055 WHIRLPOOL 07d4ad958ff668eb2e7c708b0880366248cef430998fbb39238c717a464d1d60bd7bdc07d6149537fa0e5095af3c84a00f7214ec5698edfd25ed9773ce72bd37
diff --git a/kde-apps/print-manager/print-manager-16.08.1.ebuild b/kde-apps/print-manager/print-manager-16.08.1.ebuild
new file mode 100644
index 000000000000..f408c186d985
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-16.08.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ if ! use gtk ; then
+ ewarn
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ ewarn
+ fi
+}