summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-20 18:15:30 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-26 00:11:58 +1100
commitb0db5d580b55bd526d8c5f47a48bc2cb0b641b1f (patch)
tree499e18b5c2706f317beb84a22b66d1a205c70567 /kde-apps/rocs
parentkde-apps/kblocks: Drop old (diff)
downloadgentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.tar.gz
gentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.tar.bz2
gentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.zip
kde-apps: Move kdeedu-meta 15.12.3 from kde overlay
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/rocs')
-rw-r--r--kde-apps/rocs/Manifest1
-rw-r--r--kde-apps/rocs/files/rocs-15.12.3-doctools-optional.patch29
-rw-r--r--kde-apps/rocs/rocs-15.12.3.ebuild49
3 files changed, 79 insertions, 0 deletions
diff --git a/kde-apps/rocs/Manifest b/kde-apps/rocs/Manifest
index bb203ab43b23..0a9dc6ef86fa 100644
--- a/kde-apps/rocs/Manifest
+++ b/kde-apps/rocs/Manifest
@@ -1 +1,2 @@
+DIST rocs-15.12.3.tar.xz 533420 SHA256 58fb4c5ad06d7cee8691fc13566a3d9ca26da32d6a21d1d5c1f665f11a8d835e SHA512 eb8781bdc98a36c86c4494d08d40399e3da533a1383485ba81bab363f2682a85263adeda85bb1901b9c23088052a8d78c7a8fd20c1752517fd636cab4b854e2c WHIRLPOOL 9b2bf3f142f5f6b42116f4cefdbd39a8ee43fab16d6e96dfed1f23afcf9c967f7ef96d7d1b0e1fb5967580ddc1122010141b8869259f3afa46d294bae57f29ff
DIST rocs-4.14.3.tar.xz 1146328 SHA256 c1dc2ea6b7e1ab0128a28df1f4e09d9bf83c2a1d0d22ff022a86e7f5fb98d4fc SHA512 f0c1d35fcd17473459a3f63ce731c3cf27da51d64b53383f1c4ff280e8df256b80c2797e0c9012cad92601e2155f3e79118a8b8af20af2b3ce10c7ab40ca9d53 WHIRLPOOL 985c58e94999d17f6d96c4b9eafa9fa1e8926001904cfa54600b96e33803336b8b58e9deda01a9923fa6a5f10466294672fbdd7d9de06dd8177a2ebb7cdbcc1f
diff --git a/kde-apps/rocs/files/rocs-15.12.3-doctools-optional.patch b/kde-apps/rocs/files/rocs-15.12.3-doctools-optional.patch
new file mode 100644
index 000000000000..a74464c882e3
--- /dev/null
+++ b/kde-apps/rocs/files/rocs-15.12.3-doctools-optional.patch
@@ -0,0 +1,29 @@
+commit c4d77a5348fcf18aff734ccff13dcc87582a35be
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Tue Mar 8 19:34:32 2016 +0100
+
+ Make KF5DocTools really optional
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cc71ba0..8e2c4e8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -57,7 +57,6 @@ find_package(KF5 5.15 REQUIRED COMPONENTS
+ CoreAddons
+ Crash
+ Declarative
+- DocTools
+ I18n
+ ItemViews
+ TextEditor
+@@ -80,7 +79,9 @@ remove_definitions(-DQT_NO_KEYWORDS)
+ ecm_optional_add_subdirectory(libgraphtheory)
+ ecm_optional_add_subdirectory(src)
+ ecm_optional_add_subdirectory(icons)
+-ecm_optional_add_subdirectory(doc)
++if(KF5DocTools_FOUND)
++ ecm_optional_add_subdirectory(doc)
++endif()
+
+ set_package_info(Boost "Boost C++ Libraries" "http://www.boost.org")
+ feature_summary(WHAT ALL)
diff --git a/kde-apps/rocs/rocs-15.12.3.ebuild b/kde-apps/rocs/rocs-15.12.3.ebuild
new file mode 100644
index 000000000000..2027eea46fda
--- /dev/null
+++ b/kde-apps/rocs/rocs-15.12.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.0.0"
+KDE_HANDBOOK="optional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Interface to work with Graph Theory"
+HOMEPAGE="https://www.kde.org/applications/education/rocs
+https://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS=" ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/grantlee:5
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT=test # 1/10 tests currently fails
+
+PATCHES=( "${FILESDIR}/${P}-doctools-optional.patch" )