summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:25:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:28:13 +0100
commit0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac (patch)
tree0e4a9ab3a24db08d0f6c7b61b0d5821e99bd4497 /kde-apps/thumbnailers
parentecm.eclass: cmake-utils_use_find_package -> cmake_use_find_package (diff)
downloadgentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.gz
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.bz2
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.zip
kde-apps: Add KDE Release Service 19.12.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/thumbnailers')
-rw-r--r--kde-apps/thumbnailers/Manifest1
-rw-r--r--kde-apps/thumbnailers/thumbnailers-19.12.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/Manifest b/kde-apps/thumbnailers/Manifest
index b63e703e1789..2c823a19702e 100644
--- a/kde-apps/thumbnailers/Manifest
+++ b/kde-apps/thumbnailers/Manifest
@@ -1 +1,2 @@
DIST kdegraphics-thumbnailers-19.08.3.tar.xz 43564 BLAKE2B 823310ac379467405b555a9e111ea717d87ed4f25c2fbbc415c94e7496263e1254d28e8ee1f2a7ad6ff491a32ca803260b88d85ca0fe719bd0bf2e02bdf6659f SHA512 0ad62b71fef59868ef7c4a0486c99495d769bc8e0b364410f4b7cbd0f84bf4c2e24c13a3d398eb210fde0e226a44c1939a4d8aaea2090686bd83d4582bc0df65
+DIST kdegraphics-thumbnailers-19.12.0.tar.xz 46188 BLAKE2B c5380f5c840365cf67232c15c9bf995d8ac9e1ac94d6b5febc700e38bd8c33e62bfe3a772eb0dda4439950bd40b9a354a0e8bc0d41a1c7ee3b0a238c886b770f SHA512 bf8e8f91ee345ce2a5282de392bd441d5043394ad308b042fe9624585904faaca501e96f35b6d90dd9d93e9fbc0ee1d39593217eefa291b84c5d758fb912e293
diff --git a/kde-apps/thumbnailers/thumbnailers-19.12.0.ebuild b/kde-apps/thumbnailers/thumbnailers-19.12.0.ebuild
new file mode 100644
index 000000000000..580410f92a48
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-19.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="raw"
+
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ raw? (
+ >=kde-apps/libkdcraw-${PVCUT}:5
+ >=kde-apps/libkexiv2-${PVCUT}:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package raw KF5KExiv2)
+ $(cmake_use_find_package raw KF5KDcraw)
+ )
+
+ ecm_src_configure
+}