summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-04 21:38:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-05 00:27:47 +0200
commit2721f5747e25a3bb231c9b89fed133337abe8a3a (patch)
tree10180565df644f44e1ff4666492356c9b9e8007f /kde-apps/yakuake
parentkde-apps/sweeper: drop 22.08.3 (diff)
downloadgentoo-2721f5747e25a3bb231c9b89fed133337abe8a3a.tar.gz
gentoo-2721f5747e25a3bb231c9b89fed133337abe8a3a.tar.bz2
gentoo-2721f5747e25a3bb231c9b89fed133337abe8a3a.zip
kde-apps/yakuake: drop 22.08.3-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/yakuake')
-rw-r--r--kde-apps/yakuake/Manifest1
-rw-r--r--kde-apps/yakuake/files/yakuake-22.07.90-without_x11.patch87
-rw-r--r--kde-apps/yakuake/yakuake-22.08.3-r1.ebuild58
3 files changed, 0 insertions, 146 deletions
diff --git a/kde-apps/yakuake/Manifest b/kde-apps/yakuake/Manifest
index f89dc39ca5b5..9c83d70c0cc5 100644
--- a/kde-apps/yakuake/Manifest
+++ b/kde-apps/yakuake/Manifest
@@ -1,2 +1 @@
-DIST yakuake-22.08.3.tar.xz 414092 BLAKE2B 235679d6439560cef5519a414f0177834bcd95f440b57428106e6b285a53811a4f32bce6b2ca7c8566e4567e8d9f56ea332e41b175b22d3e649e951ea7e8c794 SHA512 4f02b90d138fa741c8d30f11e409fcc7b08d8775d35e35d90c3d050bbd0f0ce5d2c46ce2c3809e8ad1362eac5661681be75ebe3703570859e4d9e8ebd62ec1d0
DIST yakuake-22.12.3.tar.xz 427964 BLAKE2B 72091a73f852d3c62b42a1ab643c77e49c6081b7d584dd1c3980dfa21b5c7f3dea0cad6eb3a571f16377536e040c74bf3b2e8c397d35e40190559846eb31cf3c SHA512 30f5e18f17e3f54b68abad54a88dbb436b750f4d01be8abdb5c3fb83ba374f8f2b3dd28fa441a335e268d871a9aa3fb17518dc8fef557d6333cf500a4125e76a
diff --git a/kde-apps/yakuake/files/yakuake-22.07.90-without_x11.patch b/kde-apps/yakuake/files/yakuake-22.07.90-without_x11.patch
deleted file mode 100644
index 2d46600e3dc2..000000000000
--- a/kde-apps/yakuake/files/yakuake-22.07.90-without_x11.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From 1213c6dfd34583b005d0a2dbe7876951a13361a2 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sat, 27 Nov 2021 14:49:51 +0100
-Subject: [PATCH] Add CMake option to build WITHOUT_X11
-
-We want to be able to build without X11 support even if some of the used
-libraries may not work w/o X11 themselves yet or need to be built with
-X11 support for other reverse dependencies.
-
-HAVE_X11 already exists and is set automagically so far, but using
--DCMAKE_DISABLE_FIND_PACKAGE_X11 will break if any dependencies list X11
-as required in their cmake config.
-
-Introducing this option means there is no behavior change by default,
-cmake will just skip finding X11 or adding unwanted features if the
-option is enabled.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 30 ++++++++++++++++--------------
- app/CMakeLists.txt | 4 ++--
- 2 files changed, 18 insertions(+), 16 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index eafad24..f9a8167 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -51,20 +51,22 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
- )
-
- if(NOT APPLE)
-- find_package(X11)
-- set(HAVE_X11 ${X11_FOUND})
--
-- if(X11_FOUND)
-- if (QT_MAJOR_VERSION EQUAL "5")
-- find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED X11Extras)
-- else()
-- find_package(Qt6 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Gui)
-- endif()
-- endif(X11_FOUND)
--
-- find_package(KF5Wayland ${KF5_MIN_VERSION} CONFIG)
-- set(HAVE_KWAYLAND ${KF5Wayland_FOUND})
--endif(NOT APPLE)
-+ option(WITHOUT_X11 "Build without X11 integration (skips finding X11)" OFF)
-+ if(NOT WITHOUT_X11)
-+ find_package(X11)
-+ set(HAVE_X11 ${X11_FOUND})
-+ if(X11_FOUND)
-+ if (QT_MAJOR_VERSION EQUAL "5")
-+ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED X11Extras)
-+ else()
-+ find_package(Qt6 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Gui)
-+ endif()
-+ endif()
-+ endif()
-+
-+ find_package(KF5Wayland ${KF5_MIN_VERSION} CONFIG)
-+ set(HAVE_KWAYLAND ${KF5Wayland_FOUND})
-+endif()
-
- add_subdirectory(app)
- add_subdirectory(data)
-diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
-index b2838ec..6ada125 100644
---- a/app/CMakeLists.txt
-+++ b/app/CMakeLists.txt
-@@ -63,13 +63,13 @@ target_link_libraries(yakuake
- KF5::WidgetsAddons
- KF5::WindowSystem)
-
--if(X11_FOUND)
-+if(HAVE_X11)
- if (TARGET Qt5::X11Extras)
- target_link_libraries(yakuake Qt5::X11Extras)
- elseif (TARGET Qt6::Gui)
- target_link_libraries(yakuake Qt6::GuiPrivate) # qtx11extras_p.h in knotificationrestrictions
- endif()
--endif(X11_FOUND)
-+endif()
-
- if(KF5Wayland_FOUND)
- target_link_libraries(yakuake KF5::WaylandClient)
---
-GitLab
-
diff --git a/kde-apps/yakuake/yakuake-22.08.3-r1.ebuild b/kde-apps/yakuake/yakuake-22.08.3-r1.ebuild
deleted file mode 100644
index 9a4b7e2e664e..000000000000
--- a/kde-apps/yakuake/yakuake-22.08.3-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PVCUT=$(ver_cut 1-3)
-KFMIN=5.96.0
-QTMIN=5.15.5
-inherit ecm gear.kde.org
-
-DESCRIPTION="Quake-style terminal emulator based on konsole"
-HOMEPAGE="https://apps.kde.org/yakuake/"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="5"
-KEYWORDS="amd64 arm64 ~loong ~ppc64 x86"
-IUSE="absolute-position"
-
-# kde-frameworks/kwindowsystem[X]: Unconditional use of KX11Extras
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtsvg-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- >=kde-apps/konsole-${PVCUT}:5
- >=kde-frameworks/karchive-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/kglobalaccel-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/knotifyconfig-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- x11-libs/libX11
- absolute-position? ( >=kde-frameworks/kwayland-${KFMIN}:5 )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-22.07.90-without_x11.patch" )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package absolute-position KF5Wayland)
- )
-
- ecm_src_configure
-}