summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 14:12:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 14:15:02 +0200
commit5af7e43d0856706bc3448b4e80711c31ebc9931e (patch)
treecc8355ab4e9018195a91ad681d70f68c81bd775c /kde-apps/yakuake
parentsys-devel/flex: keyword 2.6.4-r5 for -arm64-macos (older version only) (diff)
downloadgentoo-5af7e43d0856706bc3448b4e80711c31ebc9931e.tar.gz
gentoo-5af7e43d0856706bc3448b4e80711c31ebc9931e.tar.bz2
gentoo-5af7e43d0856706bc3448b4e80711c31ebc9931e.zip
kde-apps/yakuake: Fix build with USE=-absolute-position
Closes: https://bugs.gentoo.org/904742 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/yakuake')
-rw-r--r--kde-apps/yakuake/files/yakuake-23.04.0-missing-ifdef.patch32
-rw-r--r--kde-apps/yakuake/yakuake-23.04.0.ebuild2
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-apps/yakuake/files/yakuake-23.04.0-missing-ifdef.patch b/kde-apps/yakuake/files/yakuake-23.04.0-missing-ifdef.patch
new file mode 100644
index 000000000000..aae30407060c
--- /dev/null
+++ b/kde-apps/yakuake/files/yakuake-23.04.0-missing-ifdef.patch
@@ -0,0 +1,32 @@
+From 0901b2f27fdfb9092f7d56da2a9129fa4b5e1183 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 22 Apr 2023 14:10:34 +0200
+Subject: [PATCH] Add missing HAVE_KWAYLAND ifdef
+
+Follow-up to 91a90aa6f30e95d2927d9d089eb5c4f429677080
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ app/mainwindow.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/app/mainwindow.cpp b/app/mainwindow.cpp
+index 9f6dca0..6f21a21 100644
+--- a/app/mainwindow.cpp
++++ b/app/mainwindow.cpp
+@@ -933,10 +933,12 @@ void MainWindow::applyWindowProperties()
+ KWindowSystem::setState(winId(), NET::KeepAbove | NET::SkipTaskbar | NET::SkipPager);
+ }
+
++#if HAVE_KWAYLAND
+ if (m_isWayland && m_plasmaShellSurface) {
+ m_plasmaShellSurface->setSkipTaskbar(true);
+ m_plasmaShellSurface->setSkipSwitcher(true);
+ }
++#endif
+
+ KX11Extras::setOnAllDesktops(winId(), Settings::showOnAllDesktops());
+ KWindowEffects::enableBlurBehind(windowHandle(), m_sessionStack->wantsBlur());
+--
+2.40.0
+
diff --git a/kde-apps/yakuake/yakuake-23.04.0.ebuild b/kde-apps/yakuake/yakuake-23.04.0.ebuild
index 6ae55f80d4b7..ebae5522753a 100644
--- a/kde-apps/yakuake/yakuake-23.04.0.ebuild
+++ b/kde-apps/yakuake/yakuake-23.04.0.ebuild
@@ -47,6 +47,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-missing-ifdef.patch" ) # bug 904742
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package absolute-position KF5Wayland)