summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 22:23:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 22:51:58 +0200
commitdcde5a9e922e38fd9c51826e421bfa169353f3cc (patch)
tree00f45e3617a1728f32c24a9f37a1f5d313f72d30 /kde-apps/yakuake
parentmedia-plugins/kipi-plugins: pkgmove to kde-apps/kipi-plugins (diff)
downloadgentoo-dcde5a9e922e38fd9c51826e421bfa169353f3cc.tar.gz
gentoo-dcde5a9e922e38fd9c51826e421bfa169353f3cc.tar.bz2
gentoo-dcde5a9e922e38fd9c51826e421bfa169353f3cc.zip
kde-misc/yakuake: pkgmove to kde-apps/yakuake
Part of KDE Applications starting with 19.08 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/yakuake')
-rw-r--r--kde-apps/yakuake/Manifest2
-rw-r--r--kde-apps/yakuake/metadata.xml16
-rw-r--r--kde-apps/yakuake/yakuake-3.0.5-r1.ebuild61
3 files changed, 79 insertions, 0 deletions
diff --git a/kde-apps/yakuake/Manifest b/kde-apps/yakuake/Manifest
new file mode 100644
index 000000000000..0b9717ab7366
--- /dev/null
+++ b/kde-apps/yakuake/Manifest
@@ -0,0 +1,2 @@
+DIST yakuake-3.0.5-patches.tar.xz 4996 BLAKE2B 0ffef1bf066b962c73ef6a28251d9abf3df66b28cf324bcd2d4f49c7038ba64dd3554490534cb0b001a589c42309253a0cf77683b4f97661d0fbfc17c96e5be0 SHA512 6c66043e22e98d65230de566e4594f4c1bfdcccc229ab8b66d604bf6fa666964f8b05746eb914f65d1e52fa850010aa5016a26b629f8eec09b67548dd2b00251
+DIST yakuake-3.0.5.tar.xz 347412 BLAKE2B 964b5abdbc377b2ff3c1c37ebf4cb2537dde00d8c4178bc7db1785701dee82c600cd775a38896d8ad8976cbe14427df094c4db0c425355b0330d2e8b4fbe23cd SHA512 17640590bb87b7c27e1e336cb82141b986103af95cfae2da129b69537d89a78eb0e21a6f5fb9ab26ed9e572f9edad055264f642afee6012e1a5a5c55d9dc2d22
diff --git a/kde-apps/yakuake/metadata.xml b/kde-apps/yakuake/metadata.xml
new file mode 100644
index 000000000000..af7db56fcb83
--- /dev/null
+++ b/kde-apps/yakuake/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <longdescription>
+ YaKuake is Yet Another Kuake terminal emulator. It drops down on a configurable
+ key press (defaults to F12) with a konsole window, supports multiple tabs,
+ tabs, multiple screens and mouse wheel tab navigation amongst other features.
+ </longdescription>
+ <use>
+ <flag name="absolute-position">Use <pkg>kde-frameworks/kwayland</pkg> for absolute window positioning in KWin</flag>
+ </use>
+</pkgmetadata>
diff --git a/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild b/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..afa2667addc2
--- /dev/null
+++ b/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Quake-style terminal emulator based on konsole"
+HOMEPAGE="https://yakuake.kde.org/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz
+ https://dev.gentoo.org/~asturm/distfiles/${P}-patches.tar.xz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+IUSE="absolute-position X"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep konsole)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ absolute-position? ( $(add_frameworks_dep kwayland) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/yakuake:4
+"
+
+PATCHES=( "${WORKDIR}/${P}-patches" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package absolute-position KF5Wayland)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}