summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-15 18:21:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-15 18:23:22 +0100
commit58f0f130b112c3187b7ac48c12e56d74cf3bb3b4 (patch)
treebf58beb6674a195ffc03ffea5932ebbc43cbab75 /kde-apps
parentkde-apps/kio-extras: Add stable candidate without USE=htmlthumbs (diff)
downloadgentoo-58f0f130b112c3187b7ac48c12e56d74cf3bb3b4.tar.gz
gentoo-58f0f130b112c3187b7ac48c12e56d74cf3bb3b4.tar.bz2
gentoo-58f0f130b112c3187b7ac48c12e56d74cf3bb3b4.zip
kde-apps/kio-extras: Fix usedep on dev-qt/qtwebengine
USE=htmlthumbs actually requires qtwebengine[widgets] to be enabled. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kio-extras/kio-extras-16.12.3-r2.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/kde-apps/kio-extras/kio-extras-16.12.3-r2.ebuild b/kde-apps/kio-extras/kio-extras-16.12.3-r2.ebuild
new file mode 100644
index 000000000000..6d5321c6db41
--- /dev/null
+++ b/kde-apps/kio-extras/kio-extras-16.12.3-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+QT_MINIMAL="5.7.0"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KIO plugins present a filesystem-like view of arbitrary data"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/kio-extras"
+KEYWORDS="~amd64 ~x86"
+IUSE="activities exif htmlthumbs +man mtp openexr phonon samba +sftp slp"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive 'bzip2,lzma')
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kdnssd)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ virtual/jpeg:0
+ activities? (
+ $(add_frameworks_dep kactivities)
+ $(add_qt_dep qtsql)
+ )
+ exif? ( media-gfx/exiv2:= )
+ htmlthumbs? ( $(add_qt_dep qtwebengine 'widgets') )
+ man? ( $(add_frameworks_dep khtml) )
+ mtp? ( media-libs/libmtp:= )
+ openexr? ( media-libs/openexr )
+ phonon? ( media-libs/phonon[qt5] )
+ samba? ( net-fs/samba[client] )
+ sftp? ( net-libs/libssh:=[sftp] )
+ slp? ( net-libs/openslp )
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kded)
+"
+DEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-16.12.1-activities-optional.patch
+ "${FILESDIR}/${PN}"-16.12.1-man-optional.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package activities KF5Activities)
+ $(cmake-utils_use_find_package exif Exiv2)
+ $(cmake-utils_use_find_package htmlthumbs Qt5WebEngineWidgets)
+ $(cmake-utils_use_find_package man KF5KHtml)
+ $(cmake-utils_use_find_package mtp Mtp)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ $(cmake-utils_use_find_package phonon Phonon4Qt5)
+ $(cmake-utils_use_find_package samba Samba)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ $(cmake-utils_use_find_package slp SLP)
+ )
+
+ kde5_src_configure
+}