summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/kfilemetadata
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/kfilemetadata')
-rw-r--r--kde-base/kfilemetadata/Manifest1
-rw-r--r--kde-base/kfilemetadata/kfilemetadata-4.14.3.ebuild34
-rw-r--r--kde-base/kfilemetadata/metadata.xml9
3 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/kfilemetadata/Manifest b/kde-base/kfilemetadata/Manifest
new file mode 100644
index 000000000000..50b7d3b242d4
--- /dev/null
+++ b/kde-base/kfilemetadata/Manifest
@@ -0,0 +1 @@
+DIST kfilemetadata-4.14.3.tar.xz 35908 SHA256 3115e6ebd8b52ae9eb1016a3391b019c34fa443d6a5d9351550c5e0baf0d5371 SHA512 d7321b7e1ad755c0dc267b236a33a011377ba309d94c1497c081edad82171452595ce113428048e455b8b71f3ea480e4e76e797e31a74edd24bcf42617c59acb WHIRLPOOL 7e940864c4d9529bc3d5f8337bb9f22f09e00b653ce51b089b026ba3364c57f3f94df89f011f69e9d5500894f5f953fce29acfc7ee25b884876ada7f5f54fe86
diff --git a/kde-base/kfilemetadata/kfilemetadata-4.14.3.ebuild b/kde-base/kfilemetadata/kfilemetadata-4.14.3.ebuild
new file mode 100644
index 000000000000..3716ee7fe424
--- /dev/null
+++ b/kde-base/kfilemetadata/kfilemetadata-4.14.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="A library for extracting file metadata"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug epub exif ffmpeg mobi pdf taglib"
+
+DEPEND="
+ epub? ( app-text/ebook-tools )
+ exif? ( media-gfx/exiv2:= )
+ ffmpeg? ( virtual/ffmpeg )
+ mobi? ( $(add_kdeapps_dep kdegraphics-mobipocket) )
+ pdf? ( app-text/poppler[qt4] )
+ taglib? ( media-libs/taglib )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package epub EPub)
+ $(cmake-utils_use_find_package exif Exiv2)
+ $(cmake-utils_use_find_package ffmpeg FFmpeg)
+ $(cmake-utils_use_find_package mobi QMobipocket)
+ $(cmake-utils_use_find_package pdf PopplerQt4)
+ $(cmake-utils_use_find_package taglib Taglib)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-base/kfilemetadata/metadata.xml b/kde-base/kfilemetadata/metadata.xml
new file mode 100644
index 000000000000..ce8e2b9e73a5
--- /dev/null
+++ b/kde-base/kfilemetadata/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="epub">Adds support for reading EPUB ebook metadata</flag>
+ <flag name="mobi">Adds support for reading MOBI ebook metadata</flag>
+ </use>
+</pkgmetadata>