summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-10 23:26:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-10 23:32:26 +0200
commit1ced84c2e271684949e56356a178a0318c28e056 (patch)
tree029722f862f6b407fde6dbad3c7cae4b16748ab0 /kde-frameworks/extra-cmake-modules
parentkde-apps/incidenceeditor: Disable akonadi-mysql-incidencedatetimetest (diff)
downloadgentoo-1ced84c2e271684949e56356a178a0318c28e056.tar.gz
gentoo-1ced84c2e271684949e56356a178a0318c28e056.tar.bz2
gentoo-1ced84c2e271684949e56356a178a0318c28e056.zip
kde-frameworks/extra-cmake-modules: Fix cmake code in patch
skip-ecm_add_test-early.patch broke cmake. Closes: https://bugs.gentoo.org/837608 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/extra-cmake-modules')
-rw-r--r--kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch21
1 files changed, 11 insertions, 10 deletions
diff --git a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch
index f9eef600724c..84e192919c78 100644
--- a/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch
+++ b/kde-frameworks/extra-cmake-modules/files/extra-cmake-modules-5.93.0-skip-ecm_add_test-early.patch
@@ -1,4 +1,4 @@
-From 9b53dd107af153b88658ffa246de728a8a6fbd9d Mon Sep 17 00:00:00 2001
+From 36e435f059ee44da78e6900fded348709ea865df Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sat, 11 Jul 2020 23:04:16 +0200
Subject: [PATCH] ECMAddTests.cmake: Skip ecm_add_test early if Qt::Test is not
@@ -7,8 +7,8 @@ Subject: [PATCH] ECMAddTests.cmake: Skip ecm_add_test early if Qt::Test is not
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
modules/ECMAddTests.cmake | 9 +++++++++
- tests/ECMAddTests/CMakeLists.txt | 4 ++++
- 2 files changed, 13 insertions(+)
+ tests/ECMAddTests/CMakeLists.txt | 5 +++++
+ 2 files changed, 14 insertions(+)
diff --git a/modules/ECMAddTests.cmake b/modules/ECMAddTests.cmake
index 58c78d05..994ed1e4 100644
@@ -38,20 +38,21 @@ index 58c78d05..994ed1e4 100644
ecm_add_test(${_test_source}
NAME_PREFIX ${ARG_NAME_PREFIX}
diff --git a/tests/ECMAddTests/CMakeLists.txt b/tests/ECMAddTests/CMakeLists.txt
-index aa7e73a1..5fbc1cc7 100644
+index aa7e73a1..f9fb10cb 100644
--- a/tests/ECMAddTests/CMakeLists.txt
+++ b/tests/ECMAddTests/CMakeLists.txt
-@@ -2,6 +2,10 @@ if (QT_MAJOR_VERSION EQUAL "6")
- set(QT_VERSION_OPT "-DBUILD_WITH_QT6=ON")
- else()
+@@ -4,6 +4,11 @@ else()
set(QT_VERSION_OPT "-DBUILD_WITH_QT6=OFF")
-+
+ endif()
+
+if(NOT TARGET Qt::Test)
+ message(STATUS "WARNING: skipping tests that require Qt::Test")
+ return()
- endif()
-
++endif()
++
macro(add_check NAME)
+ string(REPLACE "." "/" dir "${NAME}")
+ string(REGEX REPLACE "[^.]*\\." "" proj "${NAME}")
--
2.35.1