summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-14 15:47:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-14 15:48:15 +0200
commit9d3b28c5d21a2b1a312e1b9f8a29776bbb4b2649 (patch)
treeb68374ed2a634ca75fceacc9c94d0fca324592e5 /kde-frameworks/frameworkintegration/frameworkintegration-5.45.0.ebuild
parentsys-devel/gcc: bump patchset of 7.3.0 up to 1.2, bug #511548 (diff)
downloadgentoo-9d3b28c5d21a2b1a312e1b9f8a29776bbb4b2649.tar.gz
gentoo-9d3b28c5d21a2b1a312e1b9f8a29776bbb4b2649.tar.bz2
gentoo-9d3b28c5d21a2b1a312e1b9f8a29776bbb4b2649.zip
kde-frameworks: Add KDE Frameworks 5.45.0
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/frameworkintegration/frameworkintegration-5.45.0.ebuild')
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.45.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.45.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.45.0.ebuild
new file mode 100644
index 000000000000..b6c0da034de8
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.45.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}