summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-13 14:00:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-13 14:03:41 +0100
commit05fb92a2c275e3cb92df2d101d1d8aa2f597b992 (patch)
treef68f0b40fe75836e84b8627bf77c4b46d69c6b60 /kde-frameworks/frameworkintegration
parentwww-apps/tt-rss: PHP 8 is not supported yet (diff)
downloadgentoo-05fb92a2c275e3cb92df2d101d1d8aa2f597b992.tar.gz
gentoo-05fb92a2c275e3cb92df2d101d1d8aa2f597b992.tar.bz2
gentoo-05fb92a2c275e3cb92df2d101d1d8aa2f597b992.zip
kde-frameworks/frameworkintegration: 5.79.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.79.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 6e00754d8ef7..74d6d1b7af90 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.77.0.tar.xz 1754776 BLAKE2B 6184144a4ae91a8853de0fc8ab6e72afba493492b1ba408e428622f8028501f342a5bc9f8fd881a55935a48d2b695e5b9c920ef674e9e1613c9cd7b1803336c7 SHA512 e388fc092c0a3e3414563add6ca2a03ad6f3a3c25093293675ae0a2df594094420b75d000f2fcfa560044b1350672db5cea9f620ad9bd4349a1ebdd271624079
DIST frameworkintegration-5.78.0.tar.xz 1754716 BLAKE2B b24907b22724b809646a94bd054ee38a99f3baa1f9ee864c42efedb65f99d4b74135435a4002e02cfcd987edf12557f34458645e11ee61bc025a7b59b026e5c5 SHA512 90737fb7662b483f21bbc12f9661fb3ae9e8a79405c0edaa3e6c5fe83b2a34c0db43a574be1deaf95950ad79e9f40e68813662526eac4ef96dcdf623268aef65
+DIST frameworkintegration-5.79.0.tar.xz 1755088 BLAKE2B fd16d82c3100dfa0f01cb4d0e493a59996543afac6c1ad13f3fe7c531f40ce74cce4fcc067d30dd53d120c6246883f73c8c03e44d39f7102f09e09f3329a8328 SHA512 29c76daff9e12a9bb1cfbb05e9ef704f116e0409550ba933f1b53a76de5ba11aa7d06a67b29659a0f38d8ff23818d213cc05147e45ab65c581944ffac8a9710f
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.79.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.79.0.ebuild
new file mode 100644
index 000000000000..8fbf5abdb53b
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.79.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}