summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-15 12:58:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-15 14:31:55 +0100
commit386a2b3b4aae0468fdce1a80683d2c76287a4d48 (patch)
treebc76153bb555db8f4e32c12072f66894d52d309a /kde-frameworks/frameworkintegration
parentsys-apps/coreutils: sh stable wrt bug #711616 (diff)
downloadgentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.tar.gz
gentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.tar.bz2
gentoo-386a2b3b4aae0468fdce1a80683d2c76287a4d48.zip
kde-frameworks: Add KDE Frameworks 5.68.0
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.68.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 554072f88c7e..7f1ff31bd111 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.67.0.tar.xz 1753624 BLAKE2B cf70bed5acf65240568aafe7b025db339550abc0226d1f560d24636e4368955028148d9dbdf47afbe2e0f98850c9112aaf7ffc02966ffb48e27814adfc7cb65c SHA512 47ec7ebc2b1067074620a5a9e39f5aa664595569fc2d4a1c591e34e9ac52502fffd51f7707a522bf4028f50064f82dfafe2c6b46faa3b0f212b766e6f2ac2186
+DIST frameworkintegration-5.68.0.tar.xz 1753932 BLAKE2B 93fd626b31a3708f929ee1f4083c3235ec359b08f0daac319833473f61af7901de9faeb5a7e82fbc9c0b9a34e32fd429ecf391c71eedaaf57f976cafff1681e1 SHA512 3aa3c8cd7d5c1b7d444be504fbf1d3ff3cabdd4c043d98436e82d57415c8d9f99158f90065cf3f06b007585dfd2d4a5a8ee978795f4f7285f0e50c52dc74e372
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.68.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.68.0.ebuild
new file mode 100644
index 000000000000..a4bb90f9557a
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.68.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}