summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 01:34:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 01:59:34 +0100
commitd43e23742628e88ba2fafa1a4db6b56e6a77ca8c (patch)
treec8109b7d784b81c325419eadf533d315181c21e5 /kde-frameworks/frameworkintegration
parentdev-util/pkgcheck: remove old (diff)
downloadgentoo-d43e23742628e88ba2fafa1a4db6b56e6a77ca8c.tar.gz
gentoo-d43e23742628e88ba2fafa1a4db6b56e6a77ca8c.tar.bz2
gentoo-d43e23742628e88ba2fafa1a4db6b56e6a77ca8c.zip
kde-frameworks/frameworkintegration: Update DEPENDs
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/files/frameworkintegration-5.66.0-unused-dep.patch25
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild49
2 files changed, 74 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/files/frameworkintegration-5.66.0-unused-dep.patch b/kde-frameworks/frameworkintegration/files/frameworkintegration-5.66.0-unused-dep.patch
new file mode 100644
index 000000000000..1e8ea5dafcc9
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/files/frameworkintegration-5.66.0-unused-dep.patch
@@ -0,0 +1,25 @@
+From 85c0bd7aa6cc635efa54e4d07c49878cfa0bb553 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 12 Jan 2020 01:24:11 +0100
+Subject: [PATCH] Drop unused dependency
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c0eb508..e6d0713 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,7 +23,7 @@ include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
+ include(KDECMakeSettings)
+
+ set(REQUIRED_QT_VERSION 5.12.0)
+-find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED DBus Widgets)
++find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Gui Widgets)
+
+
+ ecm_setup_version(PROJECT VARIABLE_PREFIX FRAMEWORKINTEGRATION
+--
+2.24.1
+
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild
new file mode 100644
index 000000000000..d81ffdb1765c
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.66.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream"
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-unused-dep.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package appstream AppStreamQt)
+ $(cmake_use_find_package appstream packagekitqt5)
+ )
+
+ ecm_src_configure
+}