summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-11 16:07:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-11 16:07:46 +0100
commit61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b (patch)
tree2f4d9b6810f4cce1a9cfa8f0a12451f9e7594651 /kde-frameworks/kauth
parentdev-python/pypy3: Inline deps and include dev-python/pycparser dep (diff)
downloadgentoo-61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b.tar.gz
gentoo-61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b.tar.bz2
gentoo-61c433dc07b3fa6b1921dcb41b927dbee0d9bc7b.zip
kde-frameworks: Add KDE Frameworks 5.40.0
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.40.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 2f3f24ea7295..08f391112f87 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.37.0.tar.xz 84568 SHA256 bc982bb8443d8a9791c4fffa20e29c9f852a7a18fa31f023d8b4efb517123f32 SHA512 b97956d8360035102c9ba489806720263a0abebc06dac0b9121377030bbc16deff96cbcdfacbd1d91a6d3bd4bc868dab068a5f833bd437669b929315450eb44a WHIRLPOOL 940b682ed172418ee1222cd30be50b8f49d2cae90262beb75678c33f74a572e7c6ac73255c4cd8752aff277eb5ac6a6929644296e8b71e4274603570cbb05c8f
DIST kauth-5.39.0.tar.xz 84876 SHA256 b184b817d155b272cf42fa748c6d3c9f1713be423551d2a74e297821f6ee7221 SHA512 28ec07f9d799e4140e238c86c600a4e9705ab8099c657ca07220c13e06bb41b62552d71852ad03736dbe9c93fd44b71d6484a5bdcc0a8c47d86e505bda000dcb WHIRLPOOL 80d98079630f061c04c5f015efe09f507abc6ad64f9413ac5b0c6ceea63358c0db27cdd554e54d7d7f6a50ec5d1875aff8ae4c92217877797d42ff8e9aa5be8a
+DIST kauth-5.40.0.tar.xz 84900 SHA256 5a27f1ef5af517662e8c0d350c7f0b20a78c6f44b5db190c16d07ba637945c1c SHA512 912e45a18f98086a35caf7b65316e4fe0defbbcc80f334bcdfd146a398cfb40abe2aa6b358d2057d457a51ba9fb61b05b1319ca3ff00edea82014919f632116a WHIRLPOOL fd4f9b50f7ace70035e0dd93dd392739a7b7c2fcdbaf4ba6ab81694883f6e8acc37530dc40ef4618ab13c6478fc5b7bbe0b08d478de61c72ea5d06a0b46757ba
diff --git a/kde-frameworks/kauth/kauth-5.40.0.ebuild b/kde-frameworks/kauth/kauth-5.40.0.ebuild
new file mode 100644
index 000000000000..4852c2fb783a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.40.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}