summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 17:05:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-14 17:06:15 +0200
commit66b09c22973a2fa441b3a4dc7d71874a8a40204a (patch)
tree2bf2d57a052b373529fd4653fbcbbe51c3095d80 /kde-frameworks/kauth
parentmedia-libs/oyranos: Drop old (diff)
downloadgentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.tar.gz
gentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.tar.bz2
gentoo-66b09c22973a2fa441b3a4dc7d71874a8a40204a.zip
kde-frameworks: Add KDE Frameworks 5.39.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.39.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 74b689356cc0..90ec9d04eb43 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.37.0.tar.xz 84568 SHA256 bc982bb8443d8a9791c4fffa20e29c9f852a7a18fa31f023d8b4efb517123f32 SHA512 b97956d8360035102c9ba489806720263a0abebc06dac0b9121377030bbc16deff96cbcdfacbd1d91a6d3bd4bc868dab068a5f833bd437669b929315450eb44a WHIRLPOOL 940b682ed172418ee1222cd30be50b8f49d2cae90262beb75678c33f74a572e7c6ac73255c4cd8752aff277eb5ac6a6929644296e8b71e4274603570cbb05c8f
DIST kauth-5.38.0.tar.xz 84804 SHA256 279af9593b3bf8b2730730877ff865944839e08d21855ea25864934fe372de8a SHA512 00b7e1a5e9149ab0a462571f5fcc60594ef0880772ea9bcb3c5e11f4c976c3de0db8b01ce1cae0639e4176a34fde00b0ab9d5b9b25474b3cbc1945098a49220d WHIRLPOOL be38607a034098be06f44fe568d8c131ceb6087df923f46d5cb19014181d52cd5fc55e6bea6cb5b3c7f0388e034884013257cd090655c115184de1522f637370
+DIST kauth-5.39.0.tar.xz 84876 SHA256 b184b817d155b272cf42fa748c6d3c9f1713be423551d2a74e297821f6ee7221 SHA512 28ec07f9d799e4140e238c86c600a4e9705ab8099c657ca07220c13e06bb41b62552d71852ad03736dbe9c93fd44b71d6484a5bdcc0a8c47d86e505bda000dcb WHIRLPOOL 80d98079630f061c04c5f015efe09f507abc6ad64f9413ac5b0c6ceea63358c0db27cdd554e54d7d7f6a50ec5d1875aff8ae4c92217877797d42ff8e9aa5be8a
diff --git a/kde-frameworks/kauth/kauth-5.39.0.ebuild b/kde-frameworks/kauth/kauth-5.39.0.ebuild
new file mode 100644
index 000000000000..4852c2fb783a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.39.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}