summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 12:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 13:58:34 +0100
commitb5f0806e00fadca2d0c9819e9ab46b0d4c2da58f (patch)
tree651d11303c1a4fdb7aae0dd382ce043ffb840404 /kde-frameworks/kauth
parentapp-emulation/qemu: bump up to 4.2.0, bug #702036 (diff)
downloadgentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.gz
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.bz2
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.zip
kde-frameworks: Add KDE Frameworks 5.65
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.65.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index b86bb0136e1c..aebeb5b6f43f 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1 +1,2 @@
DIST kauth-5.64.0.tar.xz 86028 BLAKE2B f325de80edee5afaba9733732baec53241de03d3404d6ce3f5941daa683a6edfca08cfe20172364d88e15484ecef36c145306b7603259ae30bb0b422c9b5f517 SHA512 0dfa8e62930ad7ae3b1c816428a09dc6950479e3579bc143fb7de22d55554c06f6e2501bd5bab48ca08d202097d35993f35c6877f013ad2d1f00b291b7e7e6a5
+DIST kauth-5.65.0.tar.xz 86064 BLAKE2B b6ef9726083b3637593c9936e959d21a67396250f8b5f4fcaa425dd3bc7b79c2a4ff769847cf7a810391939aab127ea2429651b5713b7339c4f64658b3410c05 SHA512 5de70c1ddf73ab7def59d057d596acc657ee54e11a7def29b37e44f8458f4c65422afb8613efd94bad83974eea428e393fe9c2d5aa8482ab410ea83cf7be7a6e
diff --git a/kde-frameworks/kauth/kauth-5.65.0.ebuild b/kde-frameworks/kauth/kauth-5.65.0.ebuild
new file mode 100644
index 000000000000..624081b296eb
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.65.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=kde-frameworks/kcoreaddons-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}