summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-02-15 03:45:01 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-02-15 03:46:01 +1100
commit308018c879d78532b4deb50754fce3b4baa9aa25 (patch)
treec239383027c2b8c67494d1a43884bb4e979733ac /kde-frameworks/kded/kded-5.19.0.ebuild
parentkde5-functions.eclass: add_{frameworks,plasma,kdeapps}_dep slot overrides (diff)
downloadgentoo-308018c879d78532b4deb50754fce3b4baa9aa25.tar.gz
gentoo-308018c879d78532b4deb50754fce3b4baa9aa25.tar.bz2
gentoo-308018c879d78532b4deb50754fce3b4baa9aa25.zip
kde-frameworks: version bump 5.19.0
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-frameworks/kded/kded-5.19.0.ebuild')
-rw-r--r--kde-frameworks/kded/kded-5.19.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-frameworks/kded/kded-5.19.0.ebuild b/kde-frameworks/kded/kded-5.19.0.ebuild
new file mode 100644
index 000000000000..4548df12de2d
--- /dev/null
+++ b/kde-frameworks/kded/kded-5.19.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Central daemon of KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kservice)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}