summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-08-14 04:58:31 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-08-14 04:59:46 +1000
commit57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b (patch)
tree2df6d3acd4cca42d1875342669d68e48a488a80c /kde-frameworks/kdesu/kdesu-5.25.0.ebuild
parentmate-extra/mate-screensaver: Drop gtk3 dep for mate-session-manager (diff)
downloadgentoo-57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b.tar.gz
gentoo-57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b.tar.bz2
gentoo-57c0f925fdbb3a53b0759b3a7cd25d67a02bd85b.zip
kde-frameworks: version bump 5.25.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/kdesu/kdesu-5.25.0.ebuild')
-rw-r--r--kde-frameworks/kdesu/kdesu-5.25.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kdesu/kdesu-5.25.0.ebuild b/kde-frameworks/kdesu/kdesu-5.25.0.ebuild
new file mode 100644
index 000000000000..cda2b212c32e
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.25.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework to handle super user actions"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}