summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-22 20:23:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-22 20:31:53 +0200
commitd88b4e52c06a53e43aef10f6f06990eaef67ba28 (patch)
treed95d04737a84d67f7325ae7f1b2b00a27b213710 /kde-frameworks/kiconthemes
parentuse.desc: Remove redundant global USE=bsf (diff)
downloadgentoo-d88b4e52c06a53e43aef10f6f06990eaef67ba28.tar.gz
gentoo-d88b4e52c06a53e43aef10f6f06990eaef67ba28.tar.bz2
gentoo-d88b4e52c06a53e43aef10f6f06990eaef67ba28.zip
kde-frameworks/kiconthemes: Fix runtime crash
See also: https://mail.kde.org/pipermail/release-team/2018-October/011116.html Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-frameworks/kiconthemes')
-rw-r--r--kde-frameworks/kiconthemes/files/kiconthemes-5.51.0-crashfix.patch24
-rw-r--r--kde-frameworks/kiconthemes/kiconthemes-5.51.0-r1.ebuild31
2 files changed, 55 insertions, 0 deletions
diff --git a/kde-frameworks/kiconthemes/files/kiconthemes-5.51.0-crashfix.patch b/kde-frameworks/kiconthemes/files/kiconthemes-5.51.0-crashfix.patch
new file mode 100644
index 000000000000..2788c89aad8c
--- /dev/null
+++ b/kde-frameworks/kiconthemes/files/kiconthemes-5.51.0-crashfix.patch
@@ -0,0 +1,24 @@
+From e0006451d5b03a9e15277ad9e7b1c8a74864b532 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ivan=20=C4=8Cuki=C4=87?= <ivan.cukic@kde.org>
+Date: Mon, 8 Oct 2018 23:12:34 +0200
+Subject: Fixing a copy-paste error
+
+---
+ src/kicondialog.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/kicondialog.cpp b/src/kicondialog.cpp
+index 1f4193e..12ccb4f 100644
+--- a/src/kicondialog.cpp
++++ b/src/kicondialog.cpp
+@@ -416,7 +416,7 @@ void KIconDialog::KIconDialogPrivate::_k_slotAcceptIcons()
+ static bool sortByFileName(const QString &path1, const QString &path2)
+ {
+ const QString fileName1 = path1.mid(path1.lastIndexOf(QLatin1Char('/')) + 1);
+- const QString fileName2 = path2.mid(path1.lastIndexOf(QLatin1Char('/')) + 1);
++ const QString fileName2 = path2.mid(path2.lastIndexOf(QLatin1Char('/')) + 1);
+ return QString::compare(fileName1, fileName2, Qt::CaseInsensitive) < 0;
+ }
+
+--
+cgit v0.11.2
diff --git a/kde-frameworks/kiconthemes/kiconthemes-5.51.0-r1.ebuild b/kde-frameworks/kiconthemes/kiconthemes-5.51.0-r1.ebuild
new file mode 100644
index 000000000000..8b932fb7c06f
--- /dev/null
+++ b/kde-frameworks/kiconthemes/kiconthemes-5.51.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for icon theming and configuration"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test" # bug 574770
+
+PATCHES=( "${FILESDIR}/${P}-crashfix.patch" )