summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-frameworks/kinit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-frameworks/kinit')
-rw-r--r--kde-frameworks/kinit/Manifest1
-rw-r--r--kde-frameworks/kinit/kinit-5.12.0.ebuild38
-rw-r--r--kde-frameworks/kinit/metadata.xml8
3 files changed, 47 insertions, 0 deletions
diff --git a/kde-frameworks/kinit/Manifest b/kde-frameworks/kinit/Manifest
new file mode 100644
index 000000000000..d582318a1fc4
--- /dev/null
+++ b/kde-frameworks/kinit/Manifest
@@ -0,0 +1 @@
+DIST kinit-5.12.0.tar.xz 117056 SHA256 9f99fe0701ab8c54184c80370e8da3188ef695da6d89825d75792b99f6e381a7 SHA512 8f46f49ae65e28f902bf2be12b1f457ca04e749f3c027c858d020b9bddeef5412f3bda88c6a5fc50198e4bb4fc91ecf3d94669aa2688bd4ff08715d44b8979eb WHIRLPOOL c2d4a1bdafc8ae74ab1c5a18c32ddfa58848b101dd32c9e9daa45ba29dc61ba0ffea71c664fe5dc4e5a373f82952cdda773dee22966fa9b8a4cb86a532723e8e
diff --git a/kde-frameworks/kinit/kinit-5.12.0.ebuild b/kde-frameworks/kinit/kinit-5.12.0.ebuild
new file mode 100644
index 000000000000..ce8210c5ac14
--- /dev/null
+++ b/kde-frameworks/kinit/kinit-5.12.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Helper library to speed up start of applications on KDE work spaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="+caps"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwindowsystem)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ x11-libs/libX11
+ caps? ( sys-libs/libcap )
+"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package caps Libcap)
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-frameworks/kinit/metadata.xml b/kde-frameworks/kinit/metadata.xml
new file mode 100644
index 000000000000..b617e623dd97
--- /dev/null
+++ b/kde-frameworks/kinit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="caps">Capabilities support for improved security and better OOM handling</flag>
+ </use>
+</pkgmetadata>