summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-frameworks/kio/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-frameworks/kio/files')
-rw-r--r--kde-frameworks/kio/files/kio-tests-optional.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-tests-optional.patch b/kde-frameworks/kio/files/kio-tests-optional.patch
new file mode 100644
index 000000000000..ca45d8853f48
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-tests-optional.patch
@@ -0,0 +1,28 @@
+--- a/CMakeLists.txt 2015-01-21 01:30:56.784894492 +0100
++++ b/CMakeLists.txt 2015-01-21 01:34:51.192505604 +0100
+@@ -57,7 +57,7 @@
+ add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
+
+ set(REQUIRED_QT_VERSION 5.2.0)
+-find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets DBus Network Concurrent Xml Test)
++find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets DBus Network Concurrent Xml)
+
+ find_package(GSSAPI)
+ set_package_properties(GSSAPI PROPERTIES DESCRIPTION "Allows KIO to make use of certain HTTP authentication services"
+@@ -85,10 +85,13 @@
+ endif()
+ include(CheckLibraryExists)
+ add_subdirectory(src)
+-add_subdirectory(autotests)
+
+-if (NOT KIOCORE_ONLY)
+-add_subdirectory(tests)
++if(BUILD_TESTING)
++ find_package(Qt5Test ${REQUIRED_QT_VERSION} CONFIG REQUIRED)
++ add_subdirectory(autotests)
++ if (NOT KIOCORE_ONLY)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ # create a Config.cmake and a ConfigVersion.cmake file and install them