summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 00:21:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:23 +0200
commit832934f31e45d450d2eaee2a9ebd501303303c43 (patch)
tree26ddfbcde55dc86490c71053a6813be8c3a8c212 /kde-frameworks/knotifications
parentmedia-gfx/digikam: Drop 6.1.0 (diff)
downloadgentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.gz
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.bz2
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.zip
kde-frameworks: Add KDE Frameworks 5.61.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/knotifications')
-rw-r--r--kde-frameworks/knotifications/Manifest1
-rw-r--r--kde-frameworks/knotifications/knotifications-5.61.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/knotifications/Manifest b/kde-frameworks/knotifications/Manifest
index 36fa77165394..c96bbd3534c8 100644
--- a/kde-frameworks/knotifications/Manifest
+++ b/kde-frameworks/knotifications/Manifest
@@ -1 +1,2 @@
DIST knotifications-5.60.0.tar.xz 114024 BLAKE2B aaeafdcf66cbd8fceb8ea0555f76d5e7886bde3cef74548313337b60169c6b843dc278dcd824dd205b9ce142c91a5e42e4f771b4a3808f44098eb98c4eefd4d1 SHA512 a386f90313a514f629b6af47a30f6b4d2ef10f079ff9f5f5f92094c627c09632ffffd5c1bc75109f4484f4d2fdd42825a3c713d59327196902ebb5d77ebea7fa
+DIST knotifications-5.61.0.tar.xz 113888 BLAKE2B 0c9ee60a5a6322eeefefbed01d5f1b9dd5a4e0e511c13705772a375386585fbcb71d0ecc1c94e42946e22bfc9258c83b10bbd7a882c6533e0e3aedb7aeea7470 SHA512 b52078ed25a3eb7606f2e579319cc00c2b3cef335e20134840d71beae91d285b0de9285dfd6d823221d8af7aadb93c19b367086984249e4e6f87581879091851
diff --git a/kde-frameworks/knotifications/knotifications-5.61.0.ebuild b/kde-frameworks/knotifications/knotifications-5.61.0.ebuild
new file mode 100644
index 000000000000..5f9bd2e2b73b
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-5.61.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework for notifying the user of an event"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="dbus nls phonon speech X"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dbus? ( dev-libs/libdbusmenu-qt[qt5(+)] )
+ !phonon? ( media-libs/libcanberra )
+ phonon? ( media-libs/phonon[qt5(+)] )
+ speech? ( $(add_qt_dep qtspeech) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package dbus dbusmenu-qt5)
+ $(cmake-utils_use_find_package !phonon Canberra)
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}