summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 01:19:43 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-10 10:58:35 +0200
commit3a433556dffc41d462cbce30e8a5c097e9f73d2f (patch)
tree4fed51d583dd7dc07364b58a762fb1fd2732177b /kde-frameworks/kpackage/kpackage-5.47.0.ebuild
parentmedia-libs/libkate: Drop 0.4.1-r2 (diff)
downloadgentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.tar.gz
gentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.tar.bz2
gentoo-3a433556dffc41d462cbce30e8a5c097e9f73d2f.zip
kde-frameworks: Add KDE Frameworks 5.47.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-frameworks/kpackage/kpackage-5.47.0.ebuild')
-rw-r--r--kde-frameworks/kpackage/kpackage-5.47.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kpackage/kpackage-5.47.0.ebuild b/kde-frameworks/kpackage/kpackage-5.47.0.ebuild
new file mode 100644
index 000000000000..8af3a802d39e
--- /dev/null
+++ b/kde-frameworks/kpackage/kpackage-5.47.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework to install and load packages of non binary content"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="man"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ #bug 650214
+ local myctestargs=( -E "(kdatecomboboxtest)" )
+ kde5_src_test
+}