summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-09 19:09:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-09 19:47:17 +0100
commit2d191df87083c3e17db0ce6e815f93883be4172c (patch)
tree609994abfb68e69f566162d204dc062c4f851434 /kde-frameworks/kpeople
parentmedia-libs/gegl: 0.2 with ffmpeg 4 (diff)
downloadgentoo-2d191df87083c3e17db0ce6e815f93883be4172c.tar.gz
gentoo-2d191df87083c3e17db0ce6e815f93883be4172c.tar.bz2
gentoo-2d191df87083c3e17db0ce6e815f93883be4172c.zip
kde-frameworks: Add KDE Frameworks 5.56.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpeople')
-rw-r--r--kde-frameworks/kpeople/Manifest1
-rw-r--r--kde-frameworks/kpeople/kpeople-5.56.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kpeople/Manifest b/kde-frameworks/kpeople/Manifest
index a2e43205e9e2..14c60f1634fa 100644
--- a/kde-frameworks/kpeople/Manifest
+++ b/kde-frameworks/kpeople/Manifest
@@ -1,2 +1,3 @@
DIST kpeople-5.54.0.tar.xz 60412 BLAKE2B 580a72a0ae7aad05d07a265f26d9de5659c5d90281ce50f81ab23b7d10e4c3eaf10e412d4dd6b208309de1c7a010f6bc0bca0e192bb7a545fde3be935a2a4dac SHA512 8f4709cfb256eb7f836d64ee5dcec9962323a8d2d4b362a01fb140af53b7b16db5dd6bd4c8246af67086bee4e2baa9b40e66e877486900c32eb51cb3483a899c
DIST kpeople-5.55.0.tar.xz 60440 BLAKE2B 56ffff137e74a5ab7a57e5af13c7ae5d1c3e8fe098600ce8b18b00662cf834196e917ff3e881bd52f0718a6a4bfed37f4d447f4a1b257ba71d498ca091847184 SHA512 25ddf41ffc43b86515e0cf9ab89c37190007ef30ee1ee119c5a8760e023d16e66fb8911ff5b6cd05f015bce8fcea31eeef7eeb085076b4a2037a302f4a1380dd
+DIST kpeople-5.56.0.tar.xz 60412 BLAKE2B 736b68e45459163fbdd58935b01863305c61f40018056ae21502dcb408fb112c784d110493bd0dd33a4e990961c2cd76f50fd5be27bf2992dcb7fc8270ffa713 SHA512 3dae9befbb7cc692fb07bb1c57d571978d7a41dca5ea56fae4034b1682b427871dd2eae7006cc6c6452ef6f6ed0665069688993dbd8b083722569975e06e440b
diff --git a/kde-frameworks/kpeople/kpeople-5.56.0.ebuild b/kde-frameworks/kpeople/kpeople-5.56.0.ebuild
new file mode 100644
index 000000000000..dbb09f0972b2
--- /dev/null
+++ b/kde-frameworks/kpeople/kpeople-5.56.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://cgit.kde.org/kpeople.git"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # personsmodeltest segfaults, bug 668192
+ local myctestargs=(
+ -j1
+ -E "(persondatatest)"
+ )
+
+ kde5_src_test
+}