summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-10-13 21:48:49 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-13 21:49:01 +1100
commit56e667185f6da23b09ba91685cc4890459475092 (patch)
tree879675991305be1819030098e1e26eb7106eac53 /kde-frameworks/kpty
parentkde-frameworks/breeze-icons: remove changes that were accidentally introduced (diff)
downloadgentoo-56e667185f6da23b09ba91685cc4890459475092.tar.gz
gentoo-56e667185f6da23b09ba91685cc4890459475092.tar.bz2
gentoo-56e667185f6da23b09ba91685cc4890459475092.zip
kde-frameworks/kpty: ensure utempter is found
Gentoo-bug: 596846 Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-frameworks/kpty')
-rw-r--r--kde-frameworks/kpty/kpty-5.27.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kpty/kpty-5.27.0-r1.ebuild b/kde-frameworks/kpty/kpty-5.27.0-r1.ebuild
new file mode 100644
index 000000000000..0bd666948d02
--- /dev/null
+++ b/kde-frameworks/kpty/kpty-5.27.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for pseudo terminal devices and running child processes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ sys-libs/libutempter
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUTEMPTER_EXECUTABLE=/usr/sbin/utempter
+ )
+
+ kde5_src_configure
+}