summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:27:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit64aa333e5583d97e0c79fbaab9e0d081306746c7 (patch)
treeafc45113905a61843b091a2cea9bc284100a34be /kde-frameworks/ktexteditor/ktexteditor-5.50.0.ebuild
parentkde-apps/kpat: Add FRAMEWORKS_MINIMAL,QT_MINIMAL defs (diff)
downloadgentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.gz
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.bz2
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.zip
kde-frameworks: Add KDE Frameworks 5.50.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/ktexteditor/ktexteditor-5.50.0.ebuild')
-rw-r--r--kde-frameworks/ktexteditor/ktexteditor-5.50.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/kde-frameworks/ktexteditor/ktexteditor-5.50.0.ebuild b/kde-frameworks/ktexteditor/ktexteditor-5.50.0.ebuild
new file mode 100644
index 000000000000..7894f7bd968c
--- /dev/null
+++ b/kde-frameworks/ktexteditor/ktexteditor-5.50.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing a full text editor component"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="editorconfig git"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ editorconfig? ( app-text/editorconfig-core-c )
+ git? ( dev-libs/libgit2:= )
+"
+DEPEND="${RDEPEND}
+ test? ( $(add_frameworks_dep kservice) )
+"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+ punt_bogus_dep Qt5 XmlPatterns
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package editorconfig EditorConfig)
+ $(cmake-utils_use_find_package git LibGit2)
+ )
+
+ kde5_src_configure
+}