summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:27:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit64aa333e5583d97e0c79fbaab9e0d081306746c7 (patch)
treeafc45113905a61843b091a2cea9bc284100a34be /kde-frameworks/purpose
parentkde-apps/kpat: Add FRAMEWORKS_MINIMAL,QT_MINIMAL defs (diff)
downloadgentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.gz
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.bz2
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.zip
kde-frameworks: Add KDE Frameworks 5.50.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.50.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 4e76b24ededa..72a2d56b4783 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.46.0.tar.xz 119424 BLAKE2B d786255ff0032e5c06414e5f42a06299d604bc76425832646b20f37887e80ed8a75eca0ff551993cb70c761241c317f14336c4e38d9bd9c4c0c971d4e461d044 SHA512 682dff7d8b160203b81bada628637c82822bf020acdd838cfc298b978b2b695ad413a40d955fd76c2bbed3c0debee4ebf17f31e34951ef50a1a75c912725c207
DIST purpose-5.49.0.tar.xz 136640 BLAKE2B 18ec37d5937e8bb943cf449533177cb07625b8021b626a9e612b3d50e23bdf157e0f71e41ac000d176b1243f84491a0d51ae94a4f81be297536199f4a3cb497d SHA512 2c737a5b7948ba25f06045a8e29126cc365019bcf8e58a561f7aae6fd6023d195ceaf47455e815a6e260962db8f59dd525c67d209966a3552675472d28116236
+DIST purpose-5.50.0.tar.xz 139080 BLAKE2B fb669bbd6ea59e4cb8e59e56a8235398c7c37266b9a2cff4ab0b402eadce0e13235e2bdac3c1de43daf87d30abec9a81a98f9d946ba29f41a6f7f9c037744378 SHA512 e56bdf3ac43e21fbb73144e2a1e79c6b29c90a113642784a573ac5c563ce81471027286e3c33ecfd38b17f36b98755b4e70cf965e2a301bdec645f9999939e0c
diff --git a/kde-frameworks/purpose/purpose-5.50.0.ebuild b/kde-frameworks/purpose/purpose-5.50.0.ebuild
new file mode 100644
index 000000000000..6ca976f20fe6
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.50.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+kaccounts"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ kaccounts? (
+ $(add_kdeapps_dep kaccounts-integration)
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kaccounts KAccounts)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if ! has_version "kde-misc/kdeconnect[app]" ; then
+ elog "Optional runtime dependency:"
+ elog "kde-misc/kdeconnect[app] (send through KDE Connect)"
+ fi
+}